Brave Browser issue

Hi everyone,

I am using the browser Brave and I can’t create a game. The error message is ‘CSRF Failed: CSRF token missing or incorrect.’
Thanks for your help.
Have good day.

Brave 0.24.0
V8 6.9.427.23
rev f657f15
Muon 8.1.6
OS Release 6.1.7601
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 69.0.3497.100

Never heard of that browser, but a similar question has turned up every now and then. Maybe there’s something there. :slight_smile:


Brave, is a newcomer, and try to enhance the way we deal with ads. It is quick to load pages, and allow me to avoid ‘Google’s perfect world’ ;D

1 Like

Well, this may sound silly, but have you tried logging out and back in? Also, please try disabling extensions if you have any, just to see if it is not one of those causing problems.

if that does not help I will ask our dev to have a look, but to be honest (although admitadely I have no deeper understanding about these tokens) it might be the browser’s issue, as the site seems to work on all major browsers, and I am unsure whether we are big enough, to try and optimize for every little browser there is :frowning: (not my decision, just my personal opinion :slight_smile: )

1 Like

Hi AdamR,
First, thanks for your quick answer and the great job you do with the OGS team to offer us a great Go server.
Second, I did what you ask me to and it not help.

Anyway, I would understand that you don’t have enough ressources to chase every single tiny errors on every tiny little browser. No worries.
Just FYI, I can create a game on Chrome and then switch to Brave once the game started. so, I will keep doing it.

Again thank you for your commitment to give us the best of GO.
Best Regards,

1 Like

Hmmm too bad (although not that surprising :smiley: )
Unfortunately that is as far as my troubleshooting skills go :smiley: let’s see if @anoek is better at this than me :stuck_out_tongue:

And sorry about the trouble.

1 Like

+1 Smurph.
oh, by the way, I am a support team member in a Broacast company and that’s one of my favorite sentence because now people call me to say ‘I had a problem with my computer and remember to turn it off and on again and it works, Thank you’.
Cool… my day are much more quieter now. ;D

1 Like

Just wait until you have a product that offers multiple ways to turn it off and on again.


In my experience (using Firefox) the CSRF Failed message is a browser issue. As @AdamR suggested, it is apparently due to an extension. A way to get around it is to open a private window, which worked in my case, because it disables the extensions. Ironically my Firefox developed another problem about six months ago, after an update. As I could not resolve it, I switched to Chrome, as you did.

Edit: Added quote, because the system again failed to show the person I was responding to.

1 Like

Since brave will soon be switching from the Firefox engine to the chromium you may not have this problem for a long time

+1 mate,
It works fine in a private tab. Many thanks.

Thanks to all of you who took time to answer.
Have a good Go day. Bye

1 Like

I also use Brave and got this issue now. As soon as I read that you solved this with private mode… I found a real solution. I had a similar issue on bitchute before. This happens when you have some old cookies from before some big update to the browser. So, the solution is to click on the lock icon in on the left of the address bar -> cookies -> and remove all
After that, open the site again in a new tab, re-login (generates new cookies) and problem solved! :slight_smile: