Can't accept listed challenges when my rank equals max rank for the game

I am using the Play tab and I have not check the “show all available” tick box. When I attempt to select a game it gives me an error saying that I’m too high a rank to play that game. I’m equal in level to the rank of the player requesting.

Why do you think it’s a bug? I bet you simply fall outside of the rank restriction set by this guy.

I suppose @GreenAsJade could maybe update his submission to also account for rank restrictions,…

It started happening today, has happened to others from messages I’m seeing in chat and I know at least two of the players I attempted to play were exactly my level. Also, two players have played me before, so they weren’t likely to be filtering. In one case I was actually below the player’s level…

That said, if I can’t play against them, I shouldn’t see them. So either there’s a bug in the processing or there’s a bug in the display.

1 Like

If it isn’t restrictions, it’s a new account and unstable rating. When I created my test account, I got to 4k but couldn’t play 4k on even because it told me “rank difference >9”.

I suggest next time this happens to you, pm these people and ask if they restricted ranks.

It does seem like a bug, though, right? You shouldn’t get the “accept” button if you can’t actually accept.

I’ll take a look when I have a chance.


I just happened again with this game:

I’ve asked General Admission if he has restrictions on rank, but he’s in game. Might back from him or not, but you may have that information in the DB. In any case, I tried to get this game with him and was declined. I’ve played him previously once before.

Update: we tried this out, and it appears that if the player trying to accept has a rank equal to the maximum limit set, then they can see the button, but they can’t actually accept.

I’m looking into it further…


This one just bumped me too… and it doesn’t have a rank filter.

I think it only shows the max rank but not the min. Maybe that one has min set?

I’m asking him in PM.

Confirmed, he is using limits: [16:06] General Admission: limit to 17 -21

This might be part of the problem:

Yes, I think you’re right there - 16.0 rounding one way or the other :slight_smile:

Unfortunately, this is in the “back end”, so @anoek will need to take a look (I traced it all the way to posting the acceptance to the back end).

1 Like

I reported it here.

1 Like