gtp2ogs help

Hello all,

I am trying to connect my bot to OGS and would like some help debugging what’s wrong. It stays in the state of “Connecting…” forever.

gtp2ogs --botid 200946 --apikey <my-key> --debug -- java -jar target/scala-2.11/gobot-assembly-1.0.jar
(node) sys is deprecated. Use util instead.
[] Connecting..

Is the Bot API down? Is there a way for me to see it connected online? How do I configure what games it will accept? Adding the debug flag didn’t seem to add any extra information.


I am having the same issue, @asdf1234 and @Tokumoto had the same problem when they put their bots up. @Tokumoto made some changes to the script that worked for both of them:

1 Like

I will give that a try this evening and let you know how it goes. Thanks for the quick reply.

1 Like

That worked! Is there a way I can limit what time settings it will accept? How many games it will try to play at once?

1 Like

Iirc that scripts limits the number of games to five. As for time, I’m still familiarizing myself with the file, so I will let you know when I find it. :wink:

My version limits the time settings with -mintime and -maxtime startup options. Multiples of mintime (per move in seconds) will set the minimum main time for Byoyomi, Fischer, etc. Likewise multiples of maxtime will set the maximum main time. You can check and change the multipliers in the code.

I tried to limit the number of simultaneous games, but the mechanism in the code is not working somehow. anoek’s official version doesn’t have the additional startup options briefly described in the file of my version in the Options section.

I am having the same problem, but I am using Tokumoto’s version already. Don’t know what to do.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.