Gtp2ogs never connects

I tried to use gtp2ogs to connect a simple bot, using my account and an Application Specific Passwords from the settings page, but it never manages to connect:

[] Connecting..

Any suggestions?

Have you had a moderator mark the bot account as an AI?

If not, PM me the username for the bot and I will get it set up. :slight_smile:

EDIT: Also, you just need the username and password for the bot, not the application passwords. The application passwords are for authentication on 3rd party apps.

1 Like

No, I didn’t know that was necessary.

However, the script doesn’t even get that far - socket.on('connect') never fires at all!

Can you post a snippet of the script somewhere? It’s hard to diagnose otherwise.

I’m just using gtp2ogs, no modifications.

Well, tell me which account the bot is and change the username and password. We’ll reconvene if that doesn’t work.

I was just connecting with this account, ‘mononofu’, as I just wanted to see if I can get something connected and how it shows up.

That won’t work. OGS specifically marks bot accounts and get2ogs needs them to be marked as such for authentication purposes. If you create a new account and let me know the username, I will mark it as an AI and set you as the owner. That account will be able to connect via gtp2ogs using the username and password for that specific account.

1 Like

You’ll also need to set an API key in the request. You can generate this on the bottom of the bot profile page, jas, i will upload an image.

1 Like

You’ll need to send that API key with the connection request.

1 Like

I understand that it won’t work with this account, but as I said above it doesn’t even reach the part where it tries to authenticate - it never executes this line:, i.e. the connect event never fires.

It seems the real problem is that the SSL certificate for is bad, if I specify --insecureggs it connects fine (and then fails with bot account unknown as expected).

Hm, i have not heard of this problem before. let me check with some other users that run bots here.

Interestingly, if I visit in the browser the connection is fine, but if I use it fails with ERR_SSL_PROTOCOL_ERROR (Chrome 49).

Similarly, if I patch the script not to include the port in the URL when trying to connect, the connection works fine.

Okay, so you’re connecting now?

Yeah, connecting works.

I tried to register a new account for the bot, but it fails with “Too many clients from this address, contact us if you need this limit increased”.

Yes, there are quite a few accounts there, do you have an old one that I can turn into a bot account?

No, these accounts belong to different people sharing the IP, I don’t have access to them.

I upped the limit, let me know if it lets you create a new one.

Great thanks, I’ve created the account ‘rustigo’.

Okay. That account is labeled as a bot with you as the owner.