Is SGF upload broken?


#1

I get repeated 500 (server Error) responses when I try to upload a Leela analysis to my SGF library… I’m wondering if it’s some peculiarity of my user agent (Firefox 62.0.2 (64-bit), Sparky Linux) or the SGF I’m trying to upload, or if it happens to everyone at the moment.


#2

You are running slow .0.3 is out :smiley:

Either way, uploads seem to work for me, would you be willing to share the .sgf?


#3

Ha! So I am.

Here is my attempted upload, wherein Leela non-Zero disagrees strenuously with nearly everything my opponent and I do in the middle game.

13870115-283-nolgo-joellercoaster-LeelaAnalysis.sgf (170.6 KB)


#4

Well, your file does not work for me either :frowning: no idea why.

other uploads from Leela work for you, or is it the first you tried?

I will have to ask someone smarter than me what the problem is, but that can take time…


#5

This is the first one I’ve tried - let me have a poke around and see if they’re all like that.


#6

OK, it must be something about that file. This Leela run works:

13797727-140-joellercoaster-DrGoPlayer-LeelaAnalysis.sgf (43.3 KB)


#7

Former sysadmin, here: Error 500 is a generic ‘Misconfiguration’ error. It could be a timeout error on a script. Could be a misconfiguration on another setting (be it asp, php, whatever the backend may be).

It could possibly be a malformed SGS from the software you are using versus the parser OGS has built? Maybe - and, forgive my playing devil’s advocate - OGS or your SGF software has an error on either importing or exporting? Maybe a support ticket and the SGF would help debugging?

All of that said, it could be an issue with how the browser is handling the upload, as well.


#8

Now might be a nice time to buzz @anoek


#9

I finally found and fixed this. The fix should be live later today.