Javascript Errors

Currently on Chrome Version 40.0.2214.94 (64-bit), Mac OSX 10.9.5, some buttons are unresponsive including the “Create a Game” button and the “Accept” button on the open game list, meaning that I cannot play a game on Chrome.

The following appears in the DevTools:

 TypeError: undefined is not a function
    at m.l.challenge (ogs.4.2-445-gc8b8608.min.js:1644)
    at ogs.4.2-445-gc8b8608.min.js:523
    at ogs.4.2-445-gc8b8608.min.js:619
    at m.$eval (ogs.4.2-445-gc8b8608.min.js:455)
    at m.$apply (ogs.4.2-445-gc8b8608.min.js:456)
    at HTMLButtonElement.<anonymous> (ogs.4.2-445-gc8b8608.min.js:619)
    at HTMLButtonElement.s.event.dispatch (ogs.4.2-445-gc8b8608.min.js:258)
    at HTMLButtonElement.a.dispatch (ogs.4.2-445-gc8b8608.min.js:1023)
    at HTMLButtonElement.m.handle (ogs.4.2-445-gc8b8608.min.js:252)

Do you have any addons installed or anything else you can think of that might be causing this? You’re not the only one to report this issue, yet I can’t seem to replicate the problem over here using chrome 40 on OSX, Linux, or Windows :frowning:

I tried disabling all of my extensions but the problem persists. I did see some new errors in the DevTools:

ogs.4.2-445-gc8b8608.min.js:434 TypeError: Cannot use 'in' operator to search for 'initial_time' in undefined
    at h (ogs.4.2-445-gc8b8608.min.js:1660)
    at new e (ogs.4.2-445-gc8b8608.min.js:1667)
    at e (ogs.4.2-445-gc8b8608.min.js:372)
    at Object.instantiate (ogs.4.2-445-gc8b8608.min.js:372)
    at $get (ogs.4.2-445-gc8b8608.min.js:408)
    at ogs.4.2-445-gc8b8608.min.js:392
    at f (ogs.4.2-445-gc8b8608.min.js:343)
    at v (ogs.4.2-445-gc8b8608.min.js:392)
    at h (ogs.4.2-445-gc8b8608.min.js:385)
    at ogs.4.2-445-gc8b8608.min.js:384
ogs.4.2-445-gc8b8608.min.js:2093 ------> seek_graph/connect
play:1 GET 404 (Not Found)

I’m seeing the same behavior. Currently:

  • Chromium 37 on Ubuntu 12.04 - cannot start games (same error as morganlaco listed above)
  • Firefox 35.0.1 on Windows 7 - cannot start games (also same error)
  • Firefox 35.0.1 on Ubuntu 12.04 - CAN start games

The difference seems to be a different JS file included in the ones that aren’t working. The ones that don’t work are using ogs.4.2-445-gc8b8608.min.js as morganlaco showed, but the one that is working has ogs.4.2-461-gd8e23a7.min.js.

So it looks like an old version of the JS may be getting included sometimes for some reason?

You might want to try clear the cache (in firefox it’s Preferences -> Advanced -> Network -> Cached Web Content -> Clear Now) and do a full refresh (ctrl+shift+r).

I’ve been seeing this error in Chrome for a while. Switching to firefox seemed to work for a bit, but now its persistent there as well. I’ve tried clearing the cache as suggested in the comments by @flowing, but no dice. I’m seeing this on:

  • Firefox 35.0.1 on OSX 10.10.2
  • Chrome 40.0.2214.94 on OSX 10.10.2

This error is now occuring for me again as well, in all three of the browsers listed in my previous post. This time, all 3 browsers have the correct ogs.4.2-461-gd8e23a7.min.js but are now unable to create or join games.

Can you guys try it out in private browsing mode / incognito mode and let us know if it works there?

Private/incognito does seem to work, even with all the same extensions and such active. What might be causing that?

We’ve been telling folks who run into this issue to clear their cookies for OGS and that tends to make everything work again. We think we’ve got an issue with stored preferences as it relates to the game configuration that’s causing the problem, we’re just trying to figure out how we can work it out such that we have stored game preferences AND not fail in this way.