My gtp2ogs bot isn't working :(

Hello again,

I recently figured out my bot: DarkPachi has stopped working.
When I connect through gtp2ogs, it shows connected and accepts the game without any problem. But the real problem is that after starting the game, it doesn’t respond at all (even the console says nothing…)!

There is an example (There are much more, but I tested them in private games):

Doesn’t even display the greeting message :confused:

I edited and tried to find errors in the code but couldn’t make it… The strange part of it, however, is when I run the same code in beta OGS, it works (what?)…

Additionally, I operate a few other bots (Mortaloid-A, X, and Floral), and all of them work properly.

Any help will be greatly appreciated.

I reinstalled node.js and gtp2ogs but still doesn’t work…

<ping> @anoek, as I don’t know who of the moderators is knowledgeable about these things.

1 Like

Thank you, I also provided a picture to provide the situation more specifically.

It is fixed now :slight_smile:


Are you able to describe how it was fixed for the benefit of anyone with the same problem that finds this topic?


Well, I just tried to edit .js files inside the gtp2ogs folder to see if fixes it. Although I messed it up, the whole gtp2ogs were corrupted. So I just replaced the files that I edited from the backup devel zip file, and it fixed it. I really don’t know what made it the magic happen :confused: