OGS Planned Maintenance Outage - July 22nd 11pm EDT


#21

It’s now working fine, seems like the browser restart helped. Thanks!


#22

After the migration, I also had the error “connection to game server lost” all the time in the game and chat. I use Firefox, but things worked fine in another browser (Chromium), indicating that the problem is on the client side. This person from chat seems to suffer from the same or similar problems:

[22:23] almoje: dang after the logo changed OGS stopped working in my firefox install completely

How I got things running again

  1. Under Edit-Preferences-Privacy, remove individual cookies, remove everything related to online-go.com.
  2. Edit-Preferences-Advanced-Network, Clear Cached Web Content.
  3. in about:config, network.http.sendRefererHeader must be set to 2 (default).
  4. Run dig online-go.com and dig ggs.online-go.com to verify that both names point to the correct address. I get 130.211.8.43 and 130.211.18.32 - your result should not be wildly different. If you do not have dig on your system, try nslookup.
  5. Fully restart Firefox and log in to OGS.

I am not 100% sure about the necessity for 1 and 2, but 3 is definitely necessary and 4-5 are probably the missing piece if it’s still not working.


#23

I tried doing the steps but my laptop Firefox is still unable to even start loading the page
My phone on the same network works fine


#24

I’ve had problems several times a day being unable to connect for minutes or hours at a time, ever since the server migration. Looking at this thread today, I checked the DNS entry: While ggs.online-go.com had updated, online-go.com was still pointing to the old address.

I ended up adding a mapping in my hosts file, which seems to have pointed it in the proper direction (after some delay, and restarting the browser)

130.211.8.43 online-go.com

#25

ugh that sucks… could it be a router that’s caching the DNS for too long? I usually recommend folks use something other than their router or their provider… Google is a good one: https://developers.google.com/speed/public-dns/


#26

It’s my employer’s DNS. I’m sure the entry will get updated eventually…