[SOLVED] Website does not load on ipad anymore

The site was working great on my ipad, but now I can’t get it to show up, no matter what - when I check the console on my desktop and I login, I get a similar problem (just straight blank screen, but it works when I refresh).

The Exception I managed to pick up in the console on my desktop Chrome was:

BlockPlayer.ts:99 Uncaught TypeError: e is not iterable
  at BlockPlayer.ts:99
  at b (data.ts:114)
  at Module.591 (BlockPlayer.ts:96)
  at r (bootstrap:78)
  at a (bootstrap:45)
  at bootstrap:151
  at bootstrap:151

It looks like the response from the Blocks API endpoint simply returned “[]”, so…

The offending code, according to chrome:

data.watch(cached.blocks, (blocks) => {
    block_state = {};
    let new_ignores = {};
    for (let entry of blocks) {
        block_state[entry.blocked] = entry;
        if (entry.block_chat) {
            new_ignores[entry.blocked] = true;
        }
    }

    for (let uid in new_ignores) {
        if (!(uid in ignores)) {
            ignoreUser(uid, true);
        }
    }
    for (let uid in ignores) {
        if (!(uid in new_ignores)) {
            unIgnoreUser(uid);
        }
    }
});

Help please?

1 Like

@anoek any thoughts?

Odd, I found now that if I log out in my normal chrome window, I’m completely unable to log back in - I just get a blank page (even with refreshes and cache disabled):

If I go incognito mode, the site loads up fine - but then when I login, I get a blank page and the top error (e not iterable). If I refresh the incognito window after login, it recovers ok.

Hope this is helpful?

1 Like

A couple of things here. I’m using Firefox and the site is relatively slow to load. I get a blank page upon sign-in, though when I refresh, it loads.

When I enter a game via link, I get an “unable to connect to incident reports” pop-up dialog and it shows “users: 0” in the bottom right (clicking the person icon reveals an empty list). This only happens once per link - as soon as I refresh/load it for the second time, it loads fine afaict.

I experienced the blank screen when I tried to connect at about 1:30 p.m. EST. Earlier I had been on OGS up to about 11:00 a.m. It never loaded for me using Chrome, Firefox, or Explorer, nor did refreshing help. At my regular go group at the library this afternoon, I asked a friend to try connecting, and he got a blank screen using a tablet, and multiple browsers, too, and the library wifi. I tried again a little while ago here at home, still a blank screen. Does not load even after a long time, nor after refreshing. Got in using an incognito window per the recommendation above (I had accessed the Forums as a guest). Looks like an OGS problem, not browser, wifi, IP, or individual computer related.

2 Likes

OK I think we’re all fixed up, let me know if anyone else has any issues

3 Likes

Fantastic, thank you so much! Confirmed all fixed up this side :slight_smile:

1 Like

Note: I block googletagmanager.

Are you still having problems?