Touch screen menu bug (random move submission)

Hi. It seems you’ve solved the mystery of instantly closing menu after tapping one of the items.

But another critical issue is out there. When I use game info, analysis mode, or even trying to switch to this forum, some random move gets posted, and sometimes even submitted immediately!

It already feels uncomfortable to ask people for undo for such a stupid reason, but none of the bugged games would be playable without it.

Tapped game info

Tapped forums

This sounds related to these. Bug: Submiting a different move

Issues mentioned there are related to some actions with the board itself. In my case it’s never touched, only main menu is used.

Oh, and the next game button tap causes this problem as well.

There are more issues on the links. One of them was that whenever anything outside of the board is clicked(touched) then a random move is inserted on the top most line.

I confirm that the issue persists only in these board coordinate display modes:

  1. None
  2. Bottom left
  3. Bottom right

Mobile devices encourage using the “none” option, because reading the board with tiny stones is very uncomfortable. So turning coordinates on is not a pleasant solution =(

When using my Android touch pad I always go back to the home screen before switching tabs. Even if I haven’t made a move on the board. This seems to prevent any random moves or other ‘clicks’ being processed.

For the first board it worked, the second one bugged after home screen like always :confused:

@anoek could you please look into it? :smile:

I’d gladly provide any additional information helping to locate this bug.
It’s really sad to use coordinates on small screens.

This is still a problem. Its happened to me on two recent games whilst playing on my Kindle Fire. When the submit button is pressed a random move is entered instead of the move highlighted on the board.

Some characteristics that may help pinpoint the issue:

  1. The move on the board was entered (and displayed correctly), but the board was scrolled up and down and then the submit button was pressed.
  2. On both occasions the move entered by OGS was on the top side of the board.

I have now got into the habit of clicking on the board where the move is displayed (effectively cancelling the move) and then clicking on the same intersection (displaying the move on the board again) and immediately clicking the submit button. Thereby ensuring no other event is processed before the submit button event.

Hope this helps.

The simple fix that worked for me is using a different browser app. I started using Firefox instead of Chrome and haven’t had a stone misplaced since.

A workaround with cancelling and restoring the stone position seems to resolve the issue by now. As for different browser usage, Firefox doesn’t fix anything on Android, and doesn’t exist on iOS. Popular software like Mercury and Opera bug as well.

Thanks for your comments guys :slight_smile: