Website crashing on all of my games

When I click either of the games I am in, I get this bug:

Congratulations, you found a bug!

Our team has been notified of the bug, however if you have more details you’d like to provide, please click here to fill out a report.

undefined is not a constructor (evaluating ‘new window.ResizeObserver(n.resizeHandler)’)

t@ div Zm@ div div div Qm@

Although my local browser should not be able to crash the server, I am using Chrome on an older iPad.

The website also crashes if I use it from Safari on the same ipad.

I haven’t been able to play any of my games in several days.


Thanks for reporting it, and definitely feel free to report these sooner.

I can open your games, which makes me think it’s not strictly your games, but maybe something in your setup or specific I mean to your setup - also the message about resizing.

@benjito might know more about this?


Oh hmm, yeah I’ve never run into that one, but I’ll look into it. @TheGarnet can you share what version of iOS you’re on?

That message, “Congratulations, you have found a bug!” is well known to anoek and some older mods, I believe. It happened a lot a couple years ago, in a variety of circumstances, devices, and browsers. There are probably old Forum threads reporting it. It seems to be an OGS problem, not a user-based problem. I got it a number of times back then when trying to set up an announcement, specifically when trying to set the time range (I am on an HP laptop using Chrome). I also got it when trying to do normal mod functions in the Forums. It never seemed to have any rhyme or reason to it.

1 Like

I had the same issue starting yesterday when browsing on my android phone using Firefox, worked fine two days ago. Issue seems to have been resolved after updating my Firefox app.

Looks like the latest version of react-resize-detector doesn’t do polyfills anymore. (Which explains why this only occurs on older browsers)

react-resize-detector was upgraded in commit 38652fe

@anoek there was a workaround in the linked issue if you think we should continue polyfilling.

import ResizeObserver from 'react-resize-detector/build/withPolyfill';

Oh that’s great, yeah we definitely should - thanks for digging into that.


I have been using Online-Go for years on this older iPad with no problems, this issue just started a few days ago. It is running iOS 12.3.1, and can not be upgraded because later versions of iOS kill a certain abandonware app that I depend on for my business.

Another iPad running iOS 14.4 is able to access my games.

I’m getting this issue on my iPad as well. Won’t let me play my games. Keeps reverting to the “congratulations you found a bug”

Is this problem fixable?

Hi, I’m getting the same bug message and I cannot use OGS anymore. Today was the first time I tried to use OGS, for a week. I am using an older mac, but I tried my newer phone and it worked fine.

Aw bummer, that workaround I posted is no longer part of react-resize-detector. I submitted an alternative fix: Add OgsResizeDetector, which does not throw on older browsers. by benjaminpjones · Pull Request #1906 · online-go/ · GitHub

At any rate, I highly recommend updating browsers if possible. Anything Safari 13+ will fix this issue! Resize Observer | Can I use... Support tables for HTML5, CSS3, etc



Im sorry I have absolutely no idea what to do with the work around fix you posted.

For everyone other than anoek, the options are

  1. Update to Safari 13+, or
  2. Wait for OGS to implement the workaround to support legacy software
1 Like

Alrighty benjito’s workaround is in place for older devices. Folks that are having trouble, can you check and see if things are working for you again?


Thank you. I’m up and running again. Fabulous
Really appreciate being able to still play on my iPad


Thank you so much! The website is working on my older ipad again!