Calling all beta testers - help us get 4.1 ready!

#23

Okay, I will wait until it is released.

0 Likes

#24

I’m using Firefox/Win7 - I don’t know if I was doing something wrong, but when I logged out of the main site I could get into the beta site fine. The first time I tried I just clicked on the link when I was still logged in here.

0 Likes

#25

Huh interesting… so is it still like that for you?

By the way you can be logged into both the beta site and the live site at the same time, they are completely isolated from each other.

0 Likes

#26

also it seems to be still happening - Just tried logging in and my username and password aren’t recognised

0 Likes

#27

Your username and password aren’t shared between systems, so you’d have to create a new user for the beta site (it can be called the same thing… we just don’t automatically import users between systems)

0 Likes

#28

Alrighty folks, I fixed up a number of the more glaring bugs, thanks for all the catches! (The rating bug made things look especially bad, I wasn’t aggregating correctly so the more people rated the worst things looked! So for those who created puzzles, folks weren’t one starring your stuff, it was just a broken system! :blush:)

I’m going to try and get this implemented tomorrow. I’d also like to get “any move” moves in, but there might be some gotchas buried in there so we’ll see if that one makes the cut or not… but isomorphisms for sure (baring unforeseen complications ;)).

@Pempu Great feedback on the tutorial, I’ll be implementing pretty much all of that.

1 Like

#29

Upon doing a review of a game between Oni and RandomBot some of black’s stones are showing up as dead when laid before they are actually dead come end game. http://beta.online-go.com/review/76

0 Likes

#30

Greetings!

I have not actually tried the new features yet, but I have some quick questions from a translator’s point of view.

  • I see the terms “puzzle”, “problem”, and “tsumego” all used. Do they refer to three different things?
  • Is a “library” the same as a “collection”? I may confuse this with the SGF library… collection… hmm questionmark
  • What is a “direct challenge” as opposed to just a challenge?
  • “Note: placing stones or changing the player color will erase any planed moves you have made in Step 2” :slight_smile:
0 Likes

#31

Hi Cab,

  • Puzzle, Problem and Tsumego are the same things. Puzzle is used in the left side menu.
  • The library is a collection of SGFs.
  • Direct challenge is when you challenge people via their profile instead of an open challenge that anyone can accept.
  • The “note” is used for Tsumego creation. Step 2 is placing the analysis upon the Tsumego, e.g: If you play here, it’s correct, and if you play here it’s wrong. - If you go back to Step 1 and change the player color or the setup moves, Step 2 is deleted.

Here are some screenshots from the beta, where some of the words are used:



0 Likes

#32

Ahh good catch thanks… although that’s kind of cool in a way :slight_smile: but i’ll get it fixed up regardless.

0 Likes

#33

Are you guys going to check for duplicate public problems or just let it ride?

0 Likes

#34

We’ll likely add a system to search for dups at some point, but probably won’t enforce uniqueness or anything.

0 Likes

#35

This has been partially resolved, when one “finishes” a problem, whether correctly or wrong, now an “Undo” button appears. But the “Reset” button is still reserved for wrong endings only. I think both buttons, the “Undo” button and the “Reset” button, should always be available, for example after one has made two moves, but has not reached “correct” or “incorrect” yet.
Even in the starting position I’d like if both buttons were there, but possibly greyed out.

Currently, when one takes multiple undos, the “Undo” button jumps up and down, depending on the length of the notes attached to the tree nodes. Maybe both the “Undo” and “Reset” button could be shown above these notes (also above “incorrect”), so one doesn’t need to chase the “Undo” button to click it multiple times (worst case)?

When I click “Reset”, a loading screen is shown for half a second. Isn’t it possible to make the “Reset” button as fluent as the undo"Undo" button?

This hasn’t been fixed yet, as far as I see.

Here is a bug related to editing problems that Oni made me notice:
I edit a problem where the starting player is black, and change the starting player to white.
Now the complete solution tree of the problem is erased, as expected.
Now I add a new move from the root node, it’s color is white, as expected.
But when I go back to the root node now, and add another move there, it’s color is black. But it should be white too.
However, when I save the problem and load it again, it’s like it should be: the first moves all have the player color.

0 Likes

#36

One more small bug:
I edit a tsumego, and choose the triangle tool (or circle, square, cross). Then I go back to place stones/make moves. Now, the half-transparent preview stones will have the symbol on top, but they shouldn’t.
This applies to both “Step 1: Setup puzzle” and “Step 2: Plan moves”.
I was surprised that this bug does not exist in game analysis boards.

0 Likes

#37

@wurfmaul Thanks for all the testing! I’ve fixed up all of those issues.

I’ve also implemented isomorphisms.

FYI, re comments, I do want to introduce those, though currently I’m debating between making those private between the commenter and the author, and making them public… not sure on that one yet.

As for the problem rankings, I imagine that’s going to be a bit of a research project to get right, though in the near future I’m going to be recording solution times, failed attempts, along with player rankings and with that data hopefully eventually we can figure out a good system for tuning those in (or at least making decent suggestions as to how difficult of a problem it is)… but for now manually setting them will have to do :slight_smile:

FYI all, our plan is to release what we have tonight so folks can create some puzzles before LGW if they want. We’ll be continuing to work on the tutorial and tsumego systems and probably release another patch on Friday to shore things up.

1 Like

#38

Thanks a lot for executing my orders so quickly :slight_smile:
A weird bug: http://online-go.com/learn-to-play-go#ko suddenly doesn’t work anymore, I can retake the ko as much as I want, I’m getting no “illegal move” message etc. . But when I build another ko and try to retake there, it’s triggered.

0 Likes

#39

Yeah working on fixing that one right now :slight_smile:

1 Like

#40

Also, if I set the size of my screen just right, this page has trouble with text wrapping and placing the board, and rapidly flips between the board all the way to the left and the board centered.

0 Likes

#41

Just in case you aren’t aware, this bug is still there.

0 Likes

#42

Bug alert: stones on a 9x9 demo board are 19x19 size. How cute! (Fix please.)

0 Likes