Auto generation of new almost empty main branch in demo

I went recently again in a bug with demo boards i ll try to describe here.

I use demo to record a go problem.
I put first black stones, white stones (with the put stones buttons, not with the play button) and after that one pass if it is white to play.
I save the position using the share variation and name it “white to play” (black if no pass)
Like this, when i link the demo, players can start investigating at the right full position snd with the right color.

Now if i edit at posteriori the infos of the demo like the names of players or the name of the demo itself (seems to be linked to the bug, but maybe not the only case), it auto generates a new main branch almost empty (1 move of the position, and the pass if it was existing) in green, parallel with the initial branch with the stones i put before.
I have to delete it
It’s not completly solved as i get a mention of it in the demo chat (with same ”white to play” namea and numerotation) which i can’t ofc delete.
So it’s still annoying as visitors of the demo will click on this mention and i guess regenerate the weird empty branch.
Besides if i don’t delete, visitor will just understand nothing, with a starting position of 1 stupid move somewhere instead of the go problem.

That did happen more as once, hope it can be reproduced and… solved.

Thanks for your attention.

1 Like

I think I’ve seen this also but I don’t know what triggers it.

I’d set up a position on a demo board, maybe change tabs to look at the forums or wherever I was getting a problem from. When I come back there would be a large empty branch with maybe one move on it at the end.

1 Like

Here that new autogenerated main branch in green has no move in it, it happens to have 1 or 2 sometimes.

1 Like