Board lines aren't straight (new issue on Firefox)

Hi all, today it seems that the lines on my board are not straight, and since they’re raster (at least on the display) the pixel-shifts are kind of jarring. I’m running OGS on Firefox 110.0 (on a Mac, if that makes any difference). I’d appreciate any insight!

Edited to add: This persists across different board colors, not just this custom one.

Fig. 1: The slightly diagonal lines, and an interesting choice of opening move by Agapanthus.


Same for me, Firefox 110.0 on Ubuntu 22.04.


Even weirder, they are straight, with respect to the screen (after all, the size of the margin between the bottom and top does not change), but there’s some anti-aliasing happening as if the grid was drawn at an angle, and then rotated back to be straight.

My best guess is that the grid is drawn at non-integer positions, and that this confuses the anti-aliasing algorithm of firefox. The effect goes away or becomes worse when you scale your browser window, supporting this hypothesis.

Here is an example in Photoshop:

From top to bottom:

  • Just a straight line
  • Line rotated 1 degree with anti-aliasing (bilinear)
  • Line rotated back 1 degree without anti-aliasing (nearest neighbour)
  • Screenshot of OGS with white background in firefox

I should note that this is a recent phenomenon; I’ve been using OGS on Firefox for a few years now, and I didn’t notice this until today. I don’t know on what side a change occurred, though.


I only started seeing this today after upgrading to firefox 110.

1 Like

I see this in the Firefox changelog, wonder if it’s related

GPU-accelerated Canvas2D is enabled by default on macOS and Linux.


Same. As soon as I upgraded to Firefox 110.0 (Linux) the boards became a mess.

1 Like

The goban appears slightly askew in Firefox, as if rotated 1 degree counter-clockwise, resulting in distracting jagged lines:

This is new behavior. Problem does not exist in Chrome.

(I popped this extra person finding this issue into this thread, and named it more clearly about Firefox)

anoek knows about this and is looking into it.


I haven’t been able to replicate this, however I just pushed up a patch that should force the use of the software renderer instead of the gpu accelerated renderer, has this fixed the issue?


Thanks anoek, It’s been fixed now for me :smiley:


It’s fixed for me as well, thank you!