Browsers cannot load threads correctly on IOS

I’ve had this issue since last update of forums. Some replies in a thread are totally empty. Threads with only a few replies seem to be fine.

I tried both safari and firefox. I also cleared data of OGS. Nothing works.

And what’s the text in “…”?

1 Like

It’s a pinned post, but for some reason on discourse, pinned means pinned until the first time you open it, and then it’ll go back to being 5+ years of threads ago or something. I’m not sure if that can be changed to make something permanently pinned to the top, because it’d be handy to access the category descriptions in full easily if they’re not short.

1 Like

Re the actual bug though, I’m not sure myself. Maybe more users with the same issue will help narrow it down.

I wonder is it posts with just images and no text, or just X that are failing to load maybe? X being some type of content or pattern.

1 Like

Sorry, but what does this mean?

Actually the entire forums are just broken. I opened this thread on an IOS device and scrolled down to the end to read all your replies, but when I went outside there was still this unread reminder. For a relatively long thread when I move the scroll bar it jumps between random replies. One thing I have noticed though, is the empty replies thing I mentioned probably occurs in a thread that has images, but I’m not sure.

Anyway, it’s totally unusable at this point. I hope we could just go to the previous version for now.

I see. I’ll try to report this on github.

Don’t bother posting to github, there’s nothing I can do for forum issues except click upgrade.

However, there was an upgrade to install, so I just installed it - can you see if that happened to fix your issue?


It seems to be a little better, but doesn’t fix completely. It looks like the issue now is, say if I want to go to 1000th reply, it tries to load the entire first 1000 replies, but I’m not sure.

I just opened a thread and scroll up to the very first post and it was okay. But when I go to like 80th reply then it doesn’t work.

It’s a typo (I think I meant bug, since it was a bug report), sometimes I don’t always catch single letters that are off by autocorrect or otherwise on mobile. I did edit it since, maybe while you were writing that reply.


Maybe report or check the discourse website/forum ?
Can’t help sorry (I am under Android/opera and it works fine )

1 Like

Hi, it seems the bug is already fixed in the most recent version of discourse: IOS 12 issue with latest version - bug - Discourse Meta
Can we have another update? Thanks.

1 Like

That was in December 2021, but yeah, thx :slight_smile:

Six days ago :slight_smile:

It’s still not fixed on my side…rip

1 Like

Actually I should’ve been aware of this, since I still have the bug on discourse forums, where the lastest version is used I suppose…

Now I’m fine with closing the thread, as I know there’s nothing much the OGS team can do.