Bug with correspondence time settings


I had an issue I thought might be worth mentioning here. I tried to create a custom correspondence game with fischer settings but I noticed a glitch when trying to select different time settings from the default ones

The default settings are 3d + 1d/move up to 1 week. However, if you change the increment to something else (say, 12h/move or smth) then it will automatically change the maximum time and won’t let you select anything for it

I tried several time and I think I’ve reliably re-created it. If you select 2d as the initial time and 16h as the increment, it will set the max time to 1day (which, of course, doesn’t make sense since the initial time is 2 days). It will change the max time to other values depending on what you have selected for the initial time and the increment. Perhaps there’s some part of the code that is referring to those inputs? I’m not sure, since I’m not a coder myself


I copied this to github for you:


Fixed in github.