Calling all testers for the next big OGS release, 4.2

Hey SimeonG,

resignation is only possible after move X, where X stands for the board size. (So after 9 moves for 9x9 board)

This also means the button to resign will appear after that number of moves. Until then, it is “cancel”. :slight_smile:

@Francisa ok. I found this a bit odd. Also, it is not very natural (I mean you should be able to resign anytime) so I think it would be normal to have that information clearly showed somewhere.

How many moves are needed on 19x19 ? I played 16 moves yesterday.

And, but that is only my opinion, why not simply showing the “resign button” all the time and simply transform “resign win” by “cancel win” if it is before a certain number of moves ?

But maybe this thread isn’t the place to talk about this… :smile:
I will keep testing the 4.2

Test : in the message box we are not able to left click on link (it is possible in room chat but not private messages)
Still we can right click and “open in a new tab” or “new window”

When posting an url or < > signs in to the in-game chat signs and urls are not seen properly.

Hey SimeonG!

I agree, that’s for a different topic. :smiley: You need 19 moves on 19x19 before you can resign instead of cancel. The “cancel” button is then transformed into “resign” like you describe it.

Great! We all owe you much! ;p

1 Like

9) I am getting a tournament invite for a tournament that does not exist anymore, and can not accept or remove it:

10) I can’t accept matburt’s friend request: :open_mouth:

Hey,

just had a nice betagame:
My opponent made a variation, then it was my opponents turn, i watched his variation (only by hovering with the mouse), he made his move so it’s my turn, but: the color of my stone has changed. (i was black and the color of the stone i could drop on the board was suddenly white) I made my move and everything was fine again (no white stone dropped to the board).

When I tried to open a review i got the message :

Server Error (500)

but after a second try it worked.

thats it so far, i hope this helps.

Playing a game with @slomogo (I suppose :smile:) I got again again the “server error 500” at first click for review, was ok at the second try (again).
And during review I clicked on “sound button”, then its color changer as you can see in the screenshot
But I wasn’t able to turn it off, or at least the color didn’t change. As I do not have a microphone (and no viewer anyway) I can’t said if it was only a “ui bug” or it was really impossible to turn it off.

Some little things:

If during the game i play the game forward in the analyze mode, and then the game continues as i have planned, the move numbers from analyze mode flash on stones for a second every time i play stone until the stones aren’t played as i played them in analyze mode.

If I’m on a game and i (accidentally) click on some of those links on top (e.g. Ladders), it asks me if i want to go out of the page and resign. If I click cancel to return to game, it doesn’t show the game and is stuck on the loading page (with that rotating ogs logo), and I have to reload again to return to the game.

Date format wrong in Finnish translation, even after refreshing the page. Should be ‘26.06.2014’ and ‘1 viik. + 1d enintään 1 viikoksi’ also search-bar in the wrong place.

TEST 1
small thing too here : I created a game, waiting for someone and the tab name is “Black turn” (see screenshot)

Steps (that I remember) :

  • create a game
  • made the mistake to click “chat”
  • reproduce @Azunjau issue (see message just above)
  • reload and back to game, then the tab name seems to be wrong

TEST 2


After the game finished, play some move with “analyze tool”, modify variation label click on “share button” and nothing has been shared.
My opponent is able to share a variation.
After reloading the page I can share a variation.

Possible source : I clicked on “revised” once and got the “server error 500”. Then tried to share the var. May it is only a consequence.

The game link : https://beta.online-go.com/game/1123

Notice that when we get the “server error 500”, the revision is created (but there is no redirection to it, after reloading I can see the link)

Edit :
TEST 3
After the game ended and after reloading the page, my opponent and myself are shown offline but we are in the game (and also visible in player list on the right)

TEST 4
When writing “d1” in game chat we got “d1

Hope it helps, thank for other testers :smile:

And another edit here !!!

TEST 5
Tried to send a message to a user which does not exists (I think) and I got that error. Tried with an existing username, worked fine.

TEST 6
Asked @Oni as friend, I cliked and the button didn’ changed. After reloading the page it is ok

but Oni doesn’t get any notification !

There is missing space between wording ‘Challenge received’ and ‘user name’.

Number of chat users is getting cut off from chat user list.

There seem to be some lag on sending and receiving notifications.

I went over to the beta site any times. I wanted to test the tournaments by entering one of the scheduled live tournaments but it needs 4 players to start. Couldn’t find 3 others who wanted to join. Considering the amount of work the devs have put into this, I think we could put in some work too. Please get over to the beta site and help us out. OGS needs you !

try to play sanbango (game series of three) with two player.

I played a game yesterday and it is still visible in preview of the chat.
You can also see it in http://beta.online-go.com/observe-games (no one is on the game)
It is not visible here : http://beta.online-go.com/play

I may help but I do some tests at random hours. Try sending me pm if you need help for anything ( pseudo : “betatesterofthedeaththanksogs” )

I was only able to take a little peek at the new beta and I must say that I really, really like this much cleaner, tidier look! Especially the window which shows the open games looks so much better with a bigger display. I also like many of the new features described above such as different ranks for live, blitz and correspondence games or the automatic site-wide tournaments. I will definitely try to play a few games there to help testing. Thanks for all your hard work to further improve OGS!!

2 Likes

First thing I did after logging in was go to settings, change the theme to dark, turned off the profanity filter, and clicked save. Was greeted by this page. Using Iceweasel (i.e. Firefox) 31.2.0. None of the addons I use seem to be causing it (NoScript, RequestPolicy, PrivacyBadger, AdBlock Edge).