Cannot download SGF file with comments

Dear experts,
our teacher just gave us a lesson on OGS but at the end of the lesson nobody was able to download the SGF with comments. How can we fix this?

The link is this:

Any help is much appreciated!


FIX: uploaded sgf files seems to present this bug. To resolve one must modify at least a name from “game informaton”. Even if it says permission denied after saving, it will work therafter.

Sorry. Usually it works without big problems.

@anoek ? Any ideas? For my review it seems to work, but not for this one.

Hi @flovo!

The sgf was previously uploaded (games where played on different servers IGS the one from teacher and KGS the one uploaded by me). When I try to upload a SGF file and then redownload it again it doesn’t work. This information may be usefull to devs, hope they can help!


1 Like

As far as I can see the comments are there… Perhaps there is just some compatibility issue with your viewer?

Try this one, see if it is what you are looking for.

review-460475_cleaned.sgf (15.8 KB)

For context - I tried when this topic was first posted, and couldn’t download at all. The link just returned an HTTP 500 response. It seems something’s been fixed since then.

Actually I couldn’t download the file even if it was without comments. And it was not only me, but nobody could download. Dunno if @AdamR has some privilege or something.

Ok I see that the game I needed now is downlowdable, but how about this one?

Oh I misunderstood the issue then, sorry. Should not be any of my priviledges, I tried from an annonymous account and works as well.

Regarding the other review I think it might have been because of a missing name, I added one and it works now, but who knows… Either way something funky thouhg, but I am off for now. Sorry about the troubles.

Ok, changing a name seems to fix this.

Thank you!


A 500 response means the server found a syntactic/semantic error with your SGF and has rejected it. You will need to guess what the problem is, fix it, and try again.

One problem I’ve encountered: the player names must not be blank.

It would be useful if the returned error message could actually describe what the problem is.