Firefox: Site loading without data

Interesting… well that’s exactly the problem I was expecting, though I was hoping there’d be something more to go off of other than “can’t connect” :frowning:

If you click on the network tab, click on one of the red failed websocket connections, is there anything interesting under the “Response” or “Security” tab?

unless I am doing it wrong the response is completely blank

the security well… Nothing interesting for me :smiley:

Well that’s very interesting, the 425 error code you’re getting is one I’ve never encountered. Probably because it’s not an official error code, one we don’t use and I don’t see any documentation that CloudFlare uses it. So, not exactly sure why you’re seeing that.

yay, I am special :tada:

4 Likes

Looks like this is a bug with Firefox people are getting a lot of places, either that or some common extension that people are using.

@AdamR Can you try now? I’ve disabled TLS 1.3, it sounds like the firefox bug might be related to that, either that or it’s a cloudflare thing… either way, I’ve disabled it, it might resolve the issue for folks

unfortunately as far as I can tell (with all extensions removed and caches purged) the issue seem unchanged

My experience is a little different. It’s been loading okay yesterday, after a shutdown. but if I log out, then the game and chat pages don’t reload, and closing and reopening doesn’t work at that point. I could not find my error console, but a search produced a list of errors, the last in November, so not relevant I think. Also, I tried opening a private window, but the preceding problem still occurs. I am on Firefox, per my earlier post.

Bummer :frowning: Well, I suspect the issue is a bit out of our hands. We haven’t pushed out any changes recently, and that’s definitely not an error code coming from us, so I suspect this is either a firefox issue that will be fixed in the nearish future, or a cloudflare issue that will be also fixed in the nearish future. Until then, I guess use Chrome, Opera, or IE?

Okay. Thanks for your investigation.

Interesting, a Firefox issue which produced similar symptoms is supposed to be fixed in the latest release (FF 59): https://bugzilla.mozilla.org/show_bug.cgi?id=1429859

I use Chrome on Android and Chrome on latest Windows OS PC.

The other day I had an Incognito tab open with my live game account but on the same device couldn’t connect to my regular account in normal tab.

It’s mildly inconvenient when it happens but not really a serious problem for me

Me three. Today Firefox has alternately failed to load the contents (=the list of available games) of either the “Play” or the “Games” toolbar item. I emptyed the cache - no effect.

I tried with Edge, no problems. Not necessarily a fair comparison as FF is my default so Edge started with more or less virgin cache and such.

Just now it started working with FF, too. That’s a bit annoying.

=====

An addition (in case it helps somebody diagnose the FF problem): At the moment everything loads in one of the tabs, but nothing loads in another. This is also annoying because usually I have several open tabs.

=====

Update (May 10): My FF updated itself to version 60.0 today. Did not help.

I had the problem of data not loading earlier today, but only after I logged in. Before I logged in, everything loaded fine. Now, data is again loading for me and I am logged in. I’ve been using Firefox the whole time.

Update: Data is not loading properly.

I have the same problem here (Firefox 59.0.3 on Linux). The following work around works for me:

Configure Firefox to use a squid proxy for HTTP and HTTPS connections (I have squid installed on my router).

1 Like

FWIW I asked about this in

https://support.mozilla.org/en-US/questions/1217169#answer-1110441

Somebody who understands the technical issues better than I do may want to add explanations of their findings.

2 Likes

Hello,

I’m having the same symptoms including the 425 error code.

I use Firefox 60 under Linux.

Arnaud

The problem might be solved now :slight_smile: anyone still experiencing the original issue?

3 Likes

Seems to be solved for Firefox. Thank you, OGS Team!

2 Likes