Firefox: Site loading without data

I’m getting a dreaded intermittent bug where the site loads without any of the data coming through. For example, the chat page will load and look correct (including my preferred channels) yet without any other users showing up in the side bar or any chat messages at all.
Or a game will load the page, but it’ll be a blank 19x19 board (regardless of the actual board size for the game) with the loading bar just sitting there, no players or player data listed, and nothing in the chat.
And in the top bar my friends and messages will be empty as well.

Refreshing occasionally works, but not always. And I have no idea whether or not it’s on my end or how to trigger it (or avoid it).


I am not a techspert but I think I was able to reproduce the symptoms you describe by pulling my connection so my best guess is that there is a problem with your connection or perhaps how often it attempts to load before giving up. Someone with more knowledge will probably like to know if you can access other sites while this issue is occuring?

I’ve been getting this on and off recently.
Seems to happen more on my pixel phone I think.

Sometimes when I have no connection on the phone there’s connection on my PC or my daughter has a connection on her tablet (same internet connection).

I’ll refresh, log out, sign back in and sometimes it’ll connect others it won’t and I’ll just have to wait until it does connect.

1 Like

I just had this happen this morning, so I think it is a site problem, not a connection problem. Everything loaded fine, except my ongoing game, which showed a loading bar. Logging out and logging in again didn’t help, so I shut down and restarted, which worked. I then logged off and went to my profile with a search, and once again the game was in a perpetual loading mode. Since my connection stayed the same during this operation, I deduce that this is a site bug. Refreshing, btw, did not work when I tried it. I’m using Firefox (51.1 I think, fully updated) with Windows 8 on an HP Pavilion laptop. @anoek
Addition: I didn’t notice it before, but now I see the chat, games tab, etc. are also not loading. This is a problem that OGS has had once or twice in the past, although not in almost a year.

1 Like

In a different thread where similar (possibly the same) problems were discussed, using Firefox was a common theme among the affected people. Any non-Firefox users experiencing this?

1 Like

I also have this problem in Firefox but not Chrome. Using a MacBook Pro.


Windows8 on laptop here too…

Using Chrome and the only time I’ve experienced this recently was when I pulled my connection to compare symptoms.

If someone who is experiencing this problem open up the error console, (Ctrl+Shift+I , click on “Console”) then do a Ctrl+Shift+R to reload the page and paste any errors you see in the log here, that would go a long way in figuring out what’s happening. Thanks!

1 Like

Purging cache actually seems to temporarily solve the problem for me.
After a normal reload (not the fancy ctrl+stuff) the page (not always) loads “blank”

and apart from some parsing warnings and stuff this:
Firefox can’t establish connection with a server wss://


seems to be an only error in the console which repeats every few seconds. Sometimes the page eventually loads given enough time, sometimes it seems not to at all.

Interesting… well that’s exactly the problem I was expecting, though I was hoping there’d be something more to go off of other than “can’t connect” :frowning:

If you click on the network tab, click on one of the red failed websocket connections, is there anything interesting under the “Response” or “Security” tab?

unless I am doing it wrong the response is completely blank

the security well… Nothing interesting for me :smiley:

Well that’s very interesting, the 425 error code you’re getting is one I’ve never encountered. Probably because it’s not an official error code, one we don’t use and I don’t see any documentation that CloudFlare uses it. So, not exactly sure why you’re seeing that.

yay, I am special :tada:


Looks like this is a bug with Firefox people are getting a lot of places, either that or some common extension that people are using.

@AdamR Can you try now? I’ve disabled TLS 1.3, it sounds like the firefox bug might be related to that, either that or it’s a cloudflare thing… either way, I’ve disabled it, it might resolve the issue for folks

unfortunately as far as I can tell (with all extensions removed and caches purged) the issue seem unchanged

My experience is a little different. It’s been loading okay yesterday, after a shutdown. but if I log out, then the game and chat pages don’t reload, and closing and reopening doesn’t work at that point. I could not find my error console, but a search produced a list of errors, the last in November, so not relevant I think. Also, I tried opening a private window, but the preceding problem still occurs. I am on Firefox, per my earlier post.

Bummer :frowning: Well, I suspect the issue is a bit out of our hands. We haven’t pushed out any changes recently, and that’s definitely not an error code coming from us, so I suspect this is either a firefox issue that will be fixed in the nearish future, or a cloudflare issue that will be also fixed in the nearish future. Until then, I guess use Chrome, Opera, or IE?

Okay. Thanks for your investigation.