How to review with AI on larger boards


I wish to review a 23x23 game with AI but on OGS it isn’t possible.

I have LizGoban on my PC but it doesn’t too. Just boards up to 19.

Do you know any other tool able to analyse a larger board?

1 Like

1 Like

@Lys KataGo has bs29 releases, they can handle max to 29*29 board.

Just download KataGo bs29 version from Releases · lightvector/KataGo · GitHub, and then use it instead of the default one (19*19 version).

1 Like

IIUC I should do this:

  1. Download the latest release of bs29 from lightvector
  2. Place these files in a folder on my PC
  3. Tell LizGoban to use that version of Katago

Is that right?
I’ll try that.

Edit: I downloaded the file “” and did like the readme says: “Run a command like this to make sure KataGo is working” but it looks like I miss a file called “default_model.bin.gz”.
Should I download it separately?

Yes, it is.

To run a Go AI (KataGo on Windows or Linux):

  • executable engine file .exe or none
  • config text file .cfg
  • neural network model .bin.gz or .txt.gz
  • GUI

For LizGoban, you need to edit its .json config file to tell where it the bs29 KataGo exe engine file. For KataGo model and KataGo config, just use the default ones.

"label": "KataGo_bs29",
            "accelerator": "F3",
            "engine": ["PATH/TO/katago", "gtp",
                       "-override-config", "analysisPVLen=50, defaultBoardSize=23",
1 Like

To see whether the .exe works fine or not, just type
./katago -h

1 Like

Between the assects of the last katago release I found this model: b18c384nbt-uec.bin.gz
I don’t know if a “default_model.bin.gz” ever existed but I used the above and worked fine with the katago test.
Now I’m gonna setup lizgoban and see if it works. :slight_smile:

1 Like

I tried to edit the config.json file for LizGoban but it doesn’t work.
I used the one available in the “sample” folder and tried to reduce it to the minimum content, but it takes forever to start or it isn’t starting at all.

    "preset": [
            "label": "KataGo (CPU)",
            "accelerator": "F1",
            "engine": [["built-in", "katago/katago-eigen"], "gtp",
                       "analysisPVLen=50, defaultBoardSize=19, homeDataDir=., logAllGTPCommunication=false, logSearchInfo=false",
                       "-model", ["built-in", "katanetwork.gz"]]
            "label": "KataGo_bs29 (larger boards)",
            "accelerator": "F3",
            "engine": ["C:<my path>/GO/LizGoban/katago_bs29/katago", "gtp",
                       "-override-config", "analysisPVLen=50, defaultBoardSize=23", homeDataDir=., logAllGTPCommunication=false, logSearchInfo=false",
                       "-model", "C:/<my path>/GO/LizGoban/katago_bs29/b18c384nbt-uec.bin.gz",
                       "-config", "C:/<my path>/GO/LizGoban/katago_bs29/default_gtp.cfg"      ]


The first part is from the sample file, the other is mine, copied from the above and edited when necessary.
Of course “my path” is a proper path.
I must be doing something wrong.
I had a problem with \ and /. In Italy we use the former for paths but in the examble I found the latter…

I’m very sorry, maybe LizGoban only support max to 19*19…

You need Sabaki, q5Go, KaTrain or Lizzie for 23*23…

I just think it’s my fault because I don’t know how to write the config.json file.

I removed the first part “KataGo (CPU)” and left just the bs29 part and had some errors.

Eventually I managed to make it work, but there’s something wrong with coordinates.

Here is move 26 in my game:

Here is move 10 on LizGoban:

It has lost a bunch of moves and has some in the wrong place (D2)

I’ll investigate if it’s a problem with the SGF file I downloaded from OGS. Maybe they’re using different coordinates letters or what.

I didn’t investigate further on LizGoban, but I installed Katrain and managed to set it up with the bs29 engine and the latest model.
It wasn’t very straightforward, but I did it!
So I had the review I was looking for.

1 Like