I can't connect to online-go.com

When I try to load the website it just presents me with the swirling go piece (or is it more an Othello piece actually) telling me it’s connecting, but it never connects.

I can (evidently) access the forums but that’s no fun if I can’t also play go! I could connect a few weeks ago, this is a new problem, but has been happening for a few days, even if I shut down my computer and restart

Any ideas?

My computer is windows 7, and neither chrome or internet explorer connects if that helps.


Hi there @bonzifan is this still an issue for you? We haven’t had any issues on our monitoring lately but a week and a half ago we migrated to some new infrastructure so if it takes your DNS a longer than normal time to update you may still be hitting our old systems.

Still no go for me, so if anyone would be able to point me in the right direction to fix it that would be wonderful :slight_smile:

What ip address is it listing for online-go.com and ggs.online-go.com for you?

The ip address for online-go.com is and the address for ggs is (they both take 9 hops)

That is definitely the right address…is this still happening? I know this was a few days ago.

Yes, still not getting anything other than the circling black and white circle.

Hey @bonzifan,

Can you open the site in chrome, open up the chrome javascript panel with ctrl-shift-j, reload the page, and see if there are any errors under the console or network tabs?

Thanks and sorry for the issues!

1 Like

Here’s what it says:
https://cdn.online-go.com/libbaduk/libbaduk-1.0.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
https://cdn.online-go.com/4.4/ogs-default.4.4-31-gec2a223.css Failed to load resource: net::ERR_INSECURE_RESPONSE
https://cdn.online-go.com/4.4/locale/countries_en.js Failed to load resource: net::ERR_INSECURE_RESPONSE
https://cdn.online-go.com/4.4/ogs.4.4-31-gec2a223.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
online-go.com/:2062 Welcome to OGS
(index):29 LOADED
(index):30 undefined
(index):2023 Starting download at 611 ms
https://cdn.online-go.com/4.4/img/ogslogo-default.png Failed to load resource: net::ERR_INSECURE_RESPONSE
https://cdn.online-go.com/4.4/img/novaicon.ico Failed to load resource: net::ERR_INSECURE_RESPONSE

1 Like

Thanks for your help :slight_smile:

1 Like

Try going to this link and look at your URL bar: https://cdn.online-go.com/4.4/img/ogslogo-default.png

It should have a green padlock. If not, something’s preventing your browser from accepting the Let’s Encrypt SSL certificate. It’s possible your computer’s date is off (these certs are super short validity, just a few months), or that your computer doesn’t have the root CA for Let’s Encrypt for some reason.


@pbgarden is exactly right, let us know what you see there.


Npe, no green padlock for me, a red one with a warning message. My computer date is correct, as for the root CA for Let’s Encrypt - how do I find out if I have that?

Steps for Chrome: On that page with the OGS logo, click the red padlock. It will bring up a “Security Overview” at the bottom, telling you why the certificate was listed as invalid. Let us know what that says. I see the following, for instance: http://i.imgur.com/rY8w24h.png


It says my connection to the site is not private because the site loaded is not a secure script. However, it also says that for this site.

Also, I just tried it and it loaded! I don’t know if something I did while fiddling with the developer tools made it load this time…?