Letter avatars broken

I closed the browser, clearing all data (cache included), and the letter avatars still worked fine. Tried CTRL+F5, just to be sure—same thing. Updating it hasn’t changed anything. Nor trying another one. So, unable to reproduce the problem on Firefox Quantum 65 and Chromium 72, both running on Arch.

Chrome version 71.0.3578.98

Point taken, it seems to still work for some people. But Walken’s (W) avatar is not using the same path as the auto-generated ones (hence it seems he saved it and uploaded it as his own but who knows), as can be seen from the URL I posted above. :stuck_out_tongue:

After @_KoBa’s post I started experiencing the problem:

The link to his avatar returns error 404—though the one @smurph posted still works.

Some letter avatars are still functional (and they follow the same path of the broken ones):

The plot thickens again, I suppose.

so it’s _KoBa’s fault?


Maybe it’s @smurph’s. I mean, bear with me: a few years from now, Skynet reads his post criticizing its embryonic incarnation and sends Alphago T-1000 back in time to sabotage his setup. Once the issue is made public, however, the android starts targeting other people in order to misdirect our attention, so we can’t link the problem from the original target to the true source.


Now pray give me my Tin Foil Hat Badge.

By “a few years from now” you probably meant “a few years back” or “a few years further back”. ;D

Rather, a few years further from now, according to The Compleat Time Journeyer’s Grammary, which will have been published somewhen in the next century.

It’s probably an issue with the CDN, if it’s only affecting some people. (I, too, have been avatar-less for the past few days.) I’ve had similar issues before on other websites. Likely, some batch of files got corrupted when they last refreshed their local copies. It should resolve itself on its own, if that’s the case, since they refresh on a regular (weekly?) basis.

1 Like

I’m not a computer guy at all, but I do know that this problem is progressive, not something that happened all at once. Would that fit your theory? I first noticed just 2 missing avatars about 2 days before this thread was started, and I mentioned it in the Moderator chat room. The next day a few more disappeared, like people disappearing in a science fiction movie. Now tonight I was composing my reply to metaphysician’s thread, left my computer with the reply still in progress, in order to make and eat dinner, came back almost 2 hours later, and my avatar had disappeared. In addition the font on the topic list has changed. The progressive nature sounds to me more like a virus, and I’m trying not to become alarmed.

1 Like

A virus affecting only letter icons over the course of many days (and for different users at different times)? No. This is not a virus.

The progress over time is because the cache of the CDN expires for each file (and region) at different times. When the CDN then tries to update the cache by asking the OGS-servers for an updated picture OGS returns a file not found error page.


I can see the letters when I’m on Chrome, but not when I’m on Firefox. @walken 's W does show up for me either way.

My conclusion: Firefox sucks.

Alternative explanation: I’m using Firefox on a computer that I kind of resurrected after its boot files passed away. I’m therefore using a bootable USB stick that allows me to use a “trial version” of Ubuntu, and so this session is only temporary.

That means there is no browsing history or cookies stored beyond a few hours ago. So maybe the other computer where I use Chrome (well, actually it’s Chromium but nevermind) is just rendering some old cached images whereas this one is trying to retrieve them and failing. This seems consistent with the CDN hypothesis.

Well, walken simply engaged in a bit of light-hearted trolling there.

As I’ve pointed out, walken’s W is a user-uploaded avatar (as we can see from the URL of that picture) and there haven’t been any issues with those.


The letter avatars are broken for me on two separate platforms:

  1. Firefox on Linux desktop
  2. Chrome on Android smartphone

I don’t think it is browser dependent, but it might be mitigated by caching. Have you tried clearing your cache on Chrome?

Looking only at the URL’s in the page source, this isn’t a browser issue. Now there might be some client-side code that is supposed to be altering these URL’s which is failing, but what I’m seeing is that these all produce a 404 error.

➭ curl -i "https://forums.online-go.com/letter_avatar_proxy/v3/letter/c/4af34b/45.png"
HTTP/2 404 
date: Thu, 21 Feb 2019 19:04:25 GMT
content-type: text/html
content-length: 162
cf-cache-status: HIT
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 4acb7a86ec84c639-MSP

<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>

I can’t put my finger on it, but did the format of the forum index page change also? If it did, is that related?

Maybe it’s just the lack of the letter icons that makes it look different.

1 Like

Yea it changed as well. Now the post summaries display the subforum they were posted in.

Right! And so there are less topics per page! Is it possible to turn that off? I went looking for an option and didn’t find one.

1 Like

Yes, it looks noticeably different and the letter avatar bug seems to have started around the same time of the change. However, note that @lucasfelix posted a screenshot showing the old forum style, but with the bug present.

I assume that the OGS devs updated the forum software (or an auto-update was pushed).

By the way, it seems that this problem is not restricted to just the OGS instance of Discourse, but has occurred with other installations as well: