Letter avatars broken

A virus affecting only letter icons over the course of many days (and for different users at different times)? No. This is not a virus.

The progress over time is because the cache of the CDN expires for each file (and region) at different times. When the CDN then tries to update the cache by asking the OGS-servers for an updated picture OGS returns a file not found error page.


I can see the letters when I’m on Chrome, but not when I’m on Firefox. @walken 's W does show up for me either way.

My conclusion: Firefox sucks.

Alternative explanation: I’m using Firefox on a computer that I kind of resurrected after its boot files passed away. I’m therefore using a bootable USB stick that allows me to use a “trial version” of Ubuntu, and so this session is only temporary.

That means there is no browsing history or cookies stored beyond a few hours ago. So maybe the other computer where I use Chrome (well, actually it’s Chromium but nevermind) is just rendering some old cached images whereas this one is trying to retrieve them and failing. This seems consistent with the CDN hypothesis.

Well, walken simply engaged in a bit of light-hearted trolling there.

As I’ve pointed out, walken’s W is a user-uploaded avatar (as we can see from the URL of that picture) and there haven’t been any issues with those.


The letter avatars are broken for me on two separate platforms:

  1. Firefox on Linux desktop
  2. Chrome on Android smartphone

I don’t think it is browser dependent, but it might be mitigated by caching. Have you tried clearing your cache on Chrome?

Looking only at the URL’s in the page source, this isn’t a browser issue. Now there might be some client-side code that is supposed to be altering these URL’s which is failing, but what I’m seeing is that these all produce a 404 error.

➭ curl -i "https://forums.online-go.com/letter_avatar_proxy/v3/letter/c/4af34b/45.png"
HTTP/2 404 
date: Thu, 21 Feb 2019 19:04:25 GMT
content-type: text/html
content-length: 162
cf-cache-status: HIT
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 4acb7a86ec84c639-MSP

<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>

I can’t put my finger on it, but did the format of the forum index page change also? If it did, is that related?

Maybe it’s just the lack of the letter icons that makes it look different.

1 Like

Yea it changed as well. Now the post summaries display the subforum they were posted in.

Right! And so there are less topics per page! Is it possible to turn that off? I went looking for an option and didn’t find one.

1 Like

Yes, it looks noticeably different and the letter avatar bug seems to have started around the same time of the change. However, note that @lucasfelix posted a screenshot showing the old forum style, but with the bug present.

I assume that the OGS devs updated the forum software (or an auto-update was pushed).

By the way, it seems that this problem is not restricted to just the OGS instance of Discourse, but has occurred with other installations as well:

We did update (https://meta.discourse.org/t/discourse-2-3-0-beta2-release-notes/108690)
But to my knowledge the problem started “long” before the update.

I will try bugging anoek if we can do more about it then just wait to see if it fixes itself from Cloudflare :slight_smile:

1 Like

Nope, no issues before,… at least not on my side of the ocean.

Hm? The update was done on Feb 19 the first report came day before that and you yourself said it happened days before. Or do we misunderstand on something? Not that it can’t be connected I guess, but don’t think it was the upgrade itself that did it.

But it is not really my area, so maybe I should stop trying to explain things I do not understand too well :smiley:

1 Like

Ah. I took the date from your link (Feb 8th).

Oh yeah, I see. No we were a little slow to catch up to the official release :slight_smile:


Well unless someone patches a CVE, it’s usually good practice to wait a little with the updating until people iron out the kinks. Otherwise… ;D

The very reason I’m not on 18.04 or whatever its decimals are.

1 Like

I mentioned the change in the index page in my post yesterday, and I can state with certainty that the change occurred simultaneous with the disappearance on my own avatar (see my post for details).

1 Like

As I mentioned in my first post, I saw the missing avatars 2 days before this thread began and mentioned it in the moderator chat. That places it on Feb 16.


For what it’s worth, we’re not the only ones with this issue: https://community.openhab.org/t/only-customized-profile-pictures-are-shown-in-forum-letter-avatar-proxy-not-available/67919


It should be noted that the current bug also makes it harder for ‘no-pic’ users to reach their forum-profile and settings page.

and then:


1 Like

Hey looks like a good ol’ fashioned reboot fixed it :slight_smile: