Live games not filtered and/or displayed correctly

Maybe it’s just me, but I think the filter for live games does some crazy stuff that is not what you would expect:

I enabled all types of games and just selected different board sizes I want to see. Look what happens:

All checked, 13 pages with 9 games per page:

(Note the page selector is visible)

Only 13x13 boards, 9 games available:

(Note there is no page selector visible.)

Only 9x9 boards, 9 games available:

(Note there is no page selector visible.)

Only 19x19 boards, 9 games available:

(Note there is no page selector visible.)

Other board sizes only, no games:

And finally:

All except other boards, 9 games available:

Well… I would expect at least 27 games over 3 pages by now?! And where the heck is the rest of the 13 pages that were shown at the very beginning?

I clicked through all that within a minute and made the screenshots. So the amount of games can’t have changed by a lot during that time. But if you do the maths on what the pages show, you will realise that when all boards except “others” are checked, there should be at least 9x3 = 27 games. Just because for each board size, it showed only 9 games. But that’s not the case.
And also how do all the games shown in the other options, sum up to 9 games x 13 pages = about 117 games that were shown when I checked all boards?

The results shown make no sense. When I only select one board type, there are definetly pages missing that should be there, but they don’t get displayed.

I deleted my cookies to hopefully make sure it’s not me. Try it for yourself, but I think something is wrong there.


As a small tip, you can upload images directly to the forum, resize them here etc


Sorry, I missed that button lol. Next time I will remember it.

That’s interesting, and thanks for updating.

It could be something weird like any non-default filter just makes the next page button disappear.

I could have a quick look and see what the logic is - it’ll be a minute or two.

1 Like

Thank you, thank you, @Holon, for your post! Over a week ago, the page selector spontaneously disappeared in Chrome when i went from Games to Home and back to Games (where it was gone). I did all the usual fixes, refreshing, logging out, and shutting down, but nothing worked. Since no one else reported this problem, I assumed it was on my end and did not bother to report it. I switched to Edge, where everything was fine for nearly a week, and then it happened there too a couple days ago.

In the meantime I discovered that if you use an incognito (private) window, the page selector is visible as usual.

I typically have everything checked except Other and Bot games. Following your post I found that the page selector returns when everything is checked, just as you said.

I work on an up-to-date HP laptop using Windows 10.

1 Like

I usually use Opera. I just tried my old Firefox, that I have not used for ages. I get the same problem. Windows 10 as well.

I think this must be a server side thing. After deleting all my Opera cookies and logging into OGS again, there shouldn’t be any weird interactions with my browser.

Edit: Just tried Google Chrome while not logged into my OGS account. Also the same results there.

1 Like

I forgot to mention that the page selector for Puzzles, Tournaments, and Groups all remain present.

So I don’t quite know exactly what’s causing it, but I have noticed that on beta, where’s there’s only 12 correspondence games, (so you can fit them all on one page), that with default filter settings it’ll show 1/1 for the pages. Then toggling whichever filter, even if it it doesn’t remove any games (like taking out 13x13 since there’s none) the 1/1 disappears.

Might require some more testing and checking values of variables etc.

1 Like

I didn’t expect this to be an easy problem. My little hobby scripts in Python are sometimes hard to debug already xD I can only imagine what amount of code you have to go through.
I just wanted to report this issue:)

1 Like

This should be fixed, thanks for reporting it!


Yup. Now it works as intended. Thanks.