New game parameter buttons text invisible on black themed ipad

Apologies if this is the wrong place for this thread - I couldn’t find a ‘bug report’ tab. When the dark theme is selected on an ipad - with either chrome or safari - when setting up a new game challenge, the text on the parameter buttons is almost invisible - being white on a silver background, where on a pc the buttons are black. :slight_smile:

This is just the right place.
I’m not an HTML expert but I’d believe that OGS web page works the “same” in all browsers. So this bug would be in the browser or iOS and not on OGS. I could be horribly wrong though. This also doesn’t mean that it shouldn’t be fixed by OGS dudes :slight_smile:

Could you provide a screenshot?
Only the “Cancel”, “Challenge” and “X” elements seem to be buttons, so I’m not sure what you experience.
For me text fields and drop downs are light grey on black while checkboxes are black on white.

1 Like

Seconded - if you could provide a screenshot that’d help immensely :slight_smile:

I regret I don’t know how to send a screenshot particularly from the ipad. I have taken a few, one of which pertains to another glitch also peculiar to the ipad, which I have only just noticed - I very rarely use it - any game selected from the ‘my games’ page fails to open. It locks with the empty board and a ‘LOADING…’ notice, but the game doesn’t load and there’s no movement of data. It only ever happens on the ipad both with chrome and safari. I suspect all of this is IOS 8.1.1 at fault. The button font issue was brought to my attention when a friend tried to set up a game from his mini ipad and was unable to do so and asked me to set one up, which process revealed just one other digital hiccup. I created a correspondence challenge timed at 3 days with 1 day per move, but when the challenge arrived it was timed at 1 day with 48 mins per move. I have tried several times from both pc and ipad with the same result. I have before after screenshots of these as well. If you tell me how to attach them I’ll send them. Should the above be split into three seperate threads? :

I beg your pardons. I was referring to the text fields which are light grey, but the font is white, so the text is lost to view. Further to the game loading failure to which I’ve referred - on the ipad I have a bookmark saved to the home screen which takes me directly to OGS and all the games do open when selected from the ‘my games’ page. This bookmark was created with safari. I have just created another for test purposes and the games open ok, where trying to open them within safari or chrome is still impossible. I rarely use this bookmark option however, because the battery status icon on the ipad sits on top of the the game number which prevents its functioning. I have a screenshot of that available also…

Doh… didn’t see the instruction right here… Here’s the screenshots.
This one shows the hidden text and also the time settings for a new game

Here’s the confirmation of that new game with different time settings

Here’s the stuck at loading screen…

and finally the OGS screen from the ipad home screen bookmark. I’ve selected the white theme for clarity, but it’s the same problem regardless of the colour.

Excellent, thanks @Debroos, I’ll make sure it’s fixed up this next patch


great - many thanks