currently broken after login

Hi, ceased working for me today. As long as I don’t login, site appears to work normally. However after logging in, All the games merely show “Loading…” (red on black) forever. Also my profile page does not show any data.

Is this a problem on my side or on OGS’ side?

This is with Firefox 59.0.3 (quantum) on Linux. With the same browser everything worked just normally yesterday and today in the morning. Tried disabling the ad-block but that didn’t change a thing.



Hello, please check above. For the moment it seems that only reliable “workaround” is using a different browser until fixed.

1 Like

Yes, firefox quantum still does not work, while konqueror “sort of works”. Looks like konqueror is not fully supported: some button are missing (e.g. cannot return to game from analyze mode), but it is sufficient for now to continue my active games.

I don’t really think that firefox is to blame, because the same firefox version worked flawlessly the previous days.

Maybe some cloudflare TLS certificates changed and now some parts of the website won’t be loaded by firefox any more? Not that there are any indications of this sort of thing happening, but I had similar problems with firefox in the past.



Some more data: the problem still persists, after login games eternally show “Loading…”. However, if I use a squid proxy to connect firefox to the internet, OGS does work. So some sort of network connection problem. Maybe IPv6 related? (I don’t have IPv6 connectivity but DNS resolves IPv6). Maybe related to HTTP/2?

Still no clue what the underlying problem is. Disabled both IPv6 and HTTP/2 support via about:config . This did not help. However, configuring firefox to use a squid proxy does reproducibly work around the problem.


Have you cleaned Firefox cache or tried running it in Private browsing session?


It is/was not a local issue, lots of people were/are affected. To keep all the info in one place, if you have any news or ideas, please post to the linked thread.