Problems when reviewing

So I am not sure if it is just me, but I’ve had a problem lately when giving a review that when in the review, my pointer is off. I will hover over something, but when I click it, it clicks on something above it. For example: I try to click on the place triangle button, and instead, it clicks on the copy branch above it.
anyway, this has happened with a few reviews I have given lately, and it is only when reviewing. It’s not a catastrophic problem, just slightly annoying. I’m just wondering if anyone else is having the same problem, and if there is anything that can be done about it.

On… mobile?

nope, on my computer. It’s very strange because it is fine any time other than when giving a review… so I know it’s not my browser or computer because all the other pages work fine.

Oooh when a customer says “I know it isn’t x”,… you know it’s most likely x. :rofl:

But yea you usually want to give some info like your OS, browser make and version… steps to reproduce, is it systematic or sporadic, etc., have you tried this on another machine,…


fair point…
well I am using a mac OS, firefox (most recent is 68.0.1).
I haven’t tried it on another system, but it has been a recurring issue in the last three reviews I have given. but only when I create a new review. If I go back and revisit a review I have done, it is not an issue.

** correction, I just created a new one and it was fine. So more of a sporadic issue


Do you by any chance have the “zoom” level on the review page other than 100%? That can cause a very similar problem to what you describe.

On firefox it should be ctrl+0 to reset to default IIRC. Otherwise I have no idea what else to try and neither recall any such similar report :open_mouth: mysterious…


Nope, there was no zoom enabled. I am trying to figure out how to reproduce the problem consistently, but as of right now it seems to be working fine again. definitely a bit of a ponderous situation and really doesn’t effect anything other than being slightly annoying when I’m reviewing. I was just curious if anyone else was having a similar problem but I guess not :-/
Thanks for the help though AdamR and Smurph. If I can figure out how to reproduce the problem, I will let you know.

1 Like

The problem seems to happen if I am in a review and open a message box or enter a review with a message box open. Then I am having the problem.

… I mean the obvious solution to this is not to message while reviewing… but that is how I am getting the problem to happen consistently.

… also, not sure if this would be a factor, but I also have multiple tabs open (chat room, the reviewed game, and forums)

**edit: well the problem happened again even without a chat box open. But I do still have multiple tabs open, so that might be part of the issue too.

1 Like

I know it might be a pain, but could you check whether the problem persists if you use another browser such as Chrome or Safari? It may help us track down the exact cause…

okay, I can give it a try and see. I have always used firefox, and given many reviews without any issue. This has only been happening in the past week or so.

I’ll let you know if safari has the same issue.


I vaguely remember @anoek saying he was looking at the game board code earlier this week… any thoughts on what this mysterious new bug could be?

The problem seems to be limited to firefox. I can not get the issue to happen in safari.

*note: I am also using private browsing with firefox. not sure if that would have an effect or not. Also used private browsing with safari, and safari had no issues.


Perhaps it is related to a specific extension in Firefox, producing this issue. Have you tried starting firefox with all extensions disabled?

1 Like

well I just tried booting firefox in safe mode and the problem persisted even in safe mode.
It seems to happen when I am all the way scrolled down on the page. I am trying to narrow down exactly what I am doing to cause this problem. It is just really strange that I am the only one with this issue and I have no idea what is causing it.
I haven’t added any sort of extension to my browser in over a year, and this problem has only occurred in the past week or so.

As a long time Firefox user (since v2.x), who stopped using the browser around v58, when they made the big changes to extension capability, I know that Firefox can be a truly fickle beast. Even with add-ons disabled, I would often encounter issues like what you are describing. “Ghost in the machine” sort of issues that could not be explained or troubleshot on the Mozzila forum.

One thing I did learn along the way was that the only way that you can be certain that your problem is related to Firefox the browser, and not any of the many files that have been altered over the years through upgrading, extensions, extension uninstalls that weren’t coded properly, potential data or cache corruption, etc… is to have an entirely new installation of Firefox.

The way I would do this in windows would be to find my Firefox profile directory, make a copy of it, uninstall Firefox in Windows, reboot, install firefox from scratch, and with the browser in that blank state, check to see if my problem still persisted. If it did, I could simply delete the current firefox folder, and return the folder I had copied and moved. The browser would work just as it did before.

If the problem persists, then it would seem to be a Firefox issue. However, we already know that it is not a Firefox browser issue, because numerous people use OGS and Firefox and this is not a widespread problem. In all likelihood this is related to your specific installation of Firefox. As annoying as it is, using Safari or any other browser to play OGS may be the easiest solution here.

I’m sorry that you are experiencing this issue. Know that you are not alone in dealing with Firefox weirdness that seemingly cannot be identified or stopped. My heart goes out to you :disappointed: