Problems with firefox


#1

Hi there,

my Firefox is broken. When I go to my OGS homepage preview thumbnails don’t work:

immagine

I’m logged in and some informations are displayed:

but I can’t view or play any game and I can’t see the number of games waiting for a move.

I had problems some time ago and they were solved by uninstalling and installing again, but this time it didn’t work.
Any thought?

I’m behind a proxy, but everything was fine until few days ago and now I have problems only with OGS. Also, OGS works well on Chrome, so maybe is something specifical between Firefox and OGS.


#2

My firefox works fine.

I sometimes have a similar problem on firefox for android. There it is usually a broken connection and reloading the page fixes it.

Can you try Crtl+Shift+R to reload OGS?


#3

Thanks, but nothing changed.

Is Ctrl+Shift+R different from F5 or the icon with the circular arrow?


#4

Yes. Ctrl+Shift+R or Ctrl+F5 froce the browser to reload all resources. Ctrl+R, F5 or the icon don’t reload the cache.

I feared so.

Can you look something up?

  1. On OGS press Ctrl+Shift+C. This opens the development console.
  2. Click on Network
  3. Reload the page with Ctrl+Shift+R
  4. Filter for socket.io
  5. There should be two entries. Look if the numbers on the left are 200 and 101. My guess is that one of the numbers is different for you.


#5

Yes, the second one seems to have problems:


#6

I have no idea how to solve the problen (or what the problem is, only that it’s not as it should be)

Some thougths

  1. the response code says ok (200) instead of
  2. the connection is not secured (the stroked lock)
  3. The type column says html instead of plain.

If you click on one of the lines a window should apear on the right. The window contains informations which could someone enable to copy your login, so be careful about posting screenshots. (if a line contains a mix of random numbers and letters, it’s probable private)

I especially wonder if the RequestURL starts with https:// and what Remote address is for you.
Your Response headers will probably be very different from mine, but the Request headers should look similar (the blue text should be the same, the pink text my be different, but should be comparable).


#7

RequestURL is the same.
Remote address is my proxy.
If I correctly understand my Response headers, proxy is closing the connection.

What I don’t understand is why it does with Firefox while it allows it for Chrome, but I fear I should ask the proxy admin.
On Chrome the situation is as you described: one 200 and one 101.


#8

I found this online:

I have the latest version installed (65.0.1)

Could it be the case? It’s recent but it should be resolved…

The bug is flagged as “duplicate of bug 1514688” that’s “verified fixed using Firefox 66.0a1 and Firefox 65.0b11

But actually I seem to have exactly that issue: “websocket via proxy not working”.


#9

According to the release notes version 65.0.1:

Fixed looping CONNECT requests when using WebSockets over HTTP/2 from behind a proxy server (bug 1523427)

That poses the question, “are you using HTTP/2 or HTTP/1.1?”


#10

I don’t know and I don’t know how to find this information either.

But maybe the question isn’t for me. :slightly_smiling_face:


#11

OGS uses HTTP1.1 for the websocket connection.


#12

I too had a problem with Firefox immediately after an update (around v55, I think) about a year ago. I consequently switch to Chrome.


#13

I’m sorry to hear that. Firefox (and/or its derivatives/spinoffs like IceWeasel / IceCat) is (are) the last bastion.

Google is in not in the business of maximizing its users’ freedom (or that of people who use other browsers - see this article for an alternative explanation for that particular grievance though), privacy or anonymity. To quote a beautiful Irish Folk song, “Both Sides of the Tweed”:

What’s the Spring breathing jasmine and rose?
What’s the Summer with all its gay train?
Or the splendor of Autumn to those
Who bartered their freedom for gain?

Melodramatic? Perhaps. But I will do my best to avoid everything Google. It’s hard enough to stomach that OGS is hosted on Google’s servers.


Letter avatars broken