Puzzle's inaccesible

Yesterday I entered some go puzzles in a newly created puzzle collection.
People have visited the collection and solved some puzzles.

Today when I want to visit the collection, I am denied acces or meet a server error.

Can some one help me?
Is it something on my side that I did wrong (maybe preferences or settings)?
Or is it something else?

This one? https://online-go.com/puzzle/21409

Seems fine to me… I assume you have tried, but simply refreshing does not help and other parts of OGS are normally accesible for you?

If you are super quick with your accesses, it is also sometimes possible to trigger visits per time period protection, though the error should be different in that case I think and should go away after a minute or two

Strange, when I searched for mu own collection I was led to
https://online-go.com/puzzle/21424” (see below), which I think doesn’t exist (at least no reaction when I click it)…
Yes, it works fine now. Thanks for looking into this, your magic eye apparently impressed the system into cooperation. :grin: