Safari sound problem

I am using Safari browser MacOS (BigSur 11.3). Everything is mute on OGS for the past week. When I click on Master Volume (or any other) play button in sound preferences nothing can be heard. This is very problematic when I play blitz games. Is there any way to fix this problem? Thank you.

2 Likes

I experience the same.

same for me. deleting cookies doesn’t help, allowing auto-play media for OGS does neither. discovered issue yesterday.

Is it a solved problem now?

Still no changes. I have contacted one of the developers, but there was no response.

Same for me.

@anoek

Sorry for the delay

What version of Safari is being used?

Can one of you open up the JavaScript console and check and see if there are any error messages?

Use the developer tools in the Develop menu in Safari on Mac - Apple Support on how to get the developer toolbar option

Thanks!

2 Likes

In Chrome (Version 87.0.4280.88 (Official Build) (x86_64)) I get things like

Access to fetch at ‘https://sentry.online-go.com/api/5/envelope/?sentry_key=…&sentry_version=7’ from origin ‘https://online-go.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

and

POST https://sentry.online-go.com/api/5/envelope/?sentry_key=…&sentry_version=7 net::ERR_FAILED

on the chat page.

I think on the home page I get

The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page.

On safari Version 10.1.2 (10603.3.8), the sounds (eg game stone ones) and settings sounds all seem to work for me on 10.10.5 Yosemite.

There are some console errors too and warnings

[Warning] ReferenceError: Can’t find variable: WebAssembly

Viewport argument key “viewport-fit” not recognized and ignored.

Origin https://online-go.com is not allowed by Access-Control-Allow-Origin.

[Error] Failed to load resource: Origin https://online-go.com is not allowed by Access-Control-Allow-Origin.

[Error] Fetch API cannot load https://sentry.online-go.com/api/5/envelope/?sentry_key=… Origin https://online-go.com is not allowed by Access-Control-Allow-Origin.

The last two seems similar to the Chrome ones.

Although in the last couple of seconds with a refresh it’s saying things like sucessfully playing sounds …

There’s a string of random stuff in the sentry key but I don’t know what it is (I’ll paste it back in if you need it)

Maybe OP and others can see if they get similar or different messages :slight_smile:

2 Likes

Good to know sound is working on your Safari - for those that sound does not work, are you using the same version as @shinuito or a different version? How do your console error messages look?

The sentry errors should be benign, I’m working on those too - but that’s not a sound thing, that’s a system I use to collect error messages… which is unfortunately erroring out after an upgrade… :disappointed:

3 Likes

I am using Safari Version 14.1 (16611.1.21.161.3).

1 Like

And I also have some errors like this in Developer Console:

2 Likes

Someone who had the problem, could you try now and see if the problem is still there?

1 Like

Still does not work on my iMac in Safari (Version 14.1).
(Mac OS Big Sur 11.3.1)

1 Like

Still the same. Nothing has changed.

1 Like

Hi Anoek, I appreciate how rapidly you respond to users encountering problems, thank you. I see no errors in the Java console, and the sound still does not work on safari.

1 Like

I found that the underlying audio library that we use had an update that addressed something in Safari 14, so I updated - did that happen to fix it?

1 Like

I’m afraid I’m still having no sound for stone placement (I hear “game started” – can’t recall if that was working previously). Maybe others with this problem can chime in as well?

1 Like

I’ve also been having sound placement issues over the past few days (Latest version of Firefox on Windows 10).

1 Like

I’m still seeing no sound in Safari

(Version 14.1 (16611.1.21.161.6))

I do see the “sound should now work” messages in the console, but no errors whatsoever, even after playing stones. I’m running MacOS Big Sur 11.3.1.

Sound is working in Firefox on the same machine.

1 Like