Stone display (not placement) bug on mobile only

I am playing white in this game:

When I look at the board in my “all games” display list, it renders correctly.

When I look at on my laptop, it renders correctly.

But when I look at it on my OnePlus One (Android phone, 1080x1920), the stone at O14 is the wrong colour (ie., black instead of white, played as w200). I nearly fell off my chair when I saw it - it changes the result of the game from comfortable white victory to comfortable black victory.

The bug does not happen in “estimate score” mode, and playing back through the moves you can see that it is played correctly. But looking at the board in “white to move” mode, it renders wrong and scares the hell out of me.

Hmm. Now I look at it having made another move, and the bug is gone.

Mysterious and unnerving. Can I not trust the game board view?

That would scare me.

A couple things that will help:

  • What is the version of Android?
  • Which app are you using to access the site (include version if you know it)?

I hope that was a case of cosmic rays and not something more serious.

This is disturbing indeed …

For clarity here’s a screenshot with O14 marked “x”

Summoning @anoek and @matburt may bring it to their attention a bit faster.

If you see the issue again please take screenshots, that’ll help with diagnosing any potential problems.

Back again, and now I’ve figured out how to take screenshots.

Android 5.1.1 (actually Cyanogenmod 12.1).

Chrome 45.0.2454.84

1 Like

Well that certainly is disconcerting, and quite puzzling.

Next time you see it, can you fork the game and send me the challenge directly?

Throughout the game, can you think of anything abnormal that has happened? Have there been pauses? Have there been undo requests, and if so, were they granted?

If you go into analyze mode now and go back to move 233, do you see the bug still?

Next time you see the bug, if you enter analyze mode, is the bug still there? If so, if you go back through the move history, when does it first appear?

Thanks for the debugging help, I’ll continue to try and reproduce it on my end here but I have yet to be able to.

1 Like

The plot thickens: I have just noticed that this game: renders correctly in the game view, but in my “all games” overview (again on my mobile only) has the stone at C15 (played as w12) rendered as black!

i have a similar problem on my phone
Android 5.1.1
Chrome 45.0.2454.94
game :
shows P14 as black
made me want to play P13 as black and it refused saying it was an illegal move
at home on PC it showed as white
when i refreshed the page the stone stayed black
when i replayed the game with backward forward controls it eventually showed white

1 Like

I tried to install dolphin browser to look at it from there but it doesnt even load the site properly. It freezes at the “connection” animation

I tried yet another browser and it showed correct!

app details:
com.cyngn.browser versie 1.02

I just made a stupid move due to this bug - I have to stop playing on mobile I think.

1 Like