Stuck in rengo game

I’ve been trying to resign from a few rengo games, but it keeps coming back to me.
the chat room shows multiple “system[9d+]: ‘chalklee’ left: Resignation” messages
which indicates that i’ve been trying to resign from the game
i need help with quitting those games.

my player name is chalklee
here are the games

1 Like

It is not clear from what you wrote whether your name is still in the list of players. It shouldn’t be. (I’m not spending time checking that monster list.)

However, be advised, the game will still appear in your list of active games, until the game concludes. That is a deliberate design, as explained in several of other threads.

1 Like

Thanks for replying.
My name is still in the list in the following game.

1 Like

There has been an update where those games are placed in a separate “Dropped Games” list.


Since pictures are worth a thousand words or whatever, I think we can all agree this shouldn’t be possible:


Yeah it’s getting high on my list to fix this … still a couple of things ahead of it, sorry.

(If anyone can show how to reproduce it, “make it happen”, so I can see it happen while I’m watching, that’d be great!)

(Darn users, for all this time they want Rengo, then when they have it, they want to leave :wink: :smiley: )


@chalklee … since you seem to be able to make it happen on our main server, can you tell me what it appears like to you straight after you resign?

Are you “still in the list”, or do you magically reappear some time later?

The more info the better - what about if you reload the page etc etc…


This is what happend right after i resign
The resign button was still there
after resign

I was still in the list before i refresh the browser tab
After refresh the browser tab, I’m no longer in the list and no resign button

The page was opened in progressive web app mode when the problem occured.
I was clicking the number on the top right corner to go through my active games.

Device: Google Pixel 6

Will update if it ever comes back


OT: How do you get a Pixel 6 to have a task bar like that?

1 Like

Sorry for the confusion.

When the problem occured(yesterday), I was using my mobile phone.

When I captured the image of me resigning from the game (today), I was using my desktop.

I switches between devices quite often.


I am back on the list
and the resign button is back

10:36 PM

1 Like

Just a thought, looking at those screenshots: Are you back in the list whenever someone else times out?


screenshot to backup your thought

I just resigned from the game, again.
The current player will probably timeout in about 8h 40m, and i’ll pay attention to that


This might be caused by the Universe trying to tell you that you should keep on playing in that game. Maybe.

1 Like

here are the screenshots I took before and after I am back to the list
I did refresh the page before I took the screenschots

Images on the left are taken before I was back in the list.
Images on the right are taken after.

Images on the top shows my name in the list
Images in middle shows resign button
Images at the bottom shows count down timer

it happened again a minute after someone timed out. it didn’t happen right away.

hope this information helps


FWIW anoek and I are boty staring at this and still not finding it.

I have set up live games on my development machine with 6 players (3 screens, 2 browsers per screen
:slight_smile: ) and tried resigning then letting the next person time out in various combinations (resigning when it was my turn, resigning when it wasn’t etc).

I couldn’t reproduce the “hey, I’m back in the game” thing.

Well keep investigating, but any more information about how to make it happen for sure will be welcome.

Anyone who’s keen can use to set up multiple accounts and experiment.

(I wonder if it only happens in correspondence - that’d make testing rather timeconsuming :open_mouth: )

1 Like

“Only in correspondence” sounds like an excellent hypothesis.


One other condition I’m guessing y’all didn’t try to reproduce manually (I wouldnt blame you!) - both reports are from Absurdly Large Rengo™ games.


We’ve tidied up a log of things that “don’t seem to be the cause, but were messy” and added improved logging to help understand what’s going on if the tidyup didn’t fix it.

Please let us know if this happens again.


I don’t know if this is related, but I noticed it, so:

This game

Doesn’t show the clock for one side.

Not within the game

Not in the game tile

I’m pretty certain it was showing until as recently as yesterday evening, because I’m running low on time in some games and was checking all my games carefully.