Trouble Installing Leela Zero on New Laptop

Only a few days ago I purchased a new laptop for the sole purpose of running Lizzie and Leela Zero. The laptop has a AMD Radeon graphics card as that is the best configuration to run Lizzie (ie: with GPU). However, when I download and install the GPU version of Leela it just dies at install time. The CPU version will install BUT when I go to run Lizzie it just says that the engine is loading and hangs.

I checked the log window and it gets hung up at the stage where it queries the openCL version.I checked the specs for the graphics card and it supports openCL.

After much googling around I’ve given up on trying to get Leela to work on the laptop and am sending it back :frowning:

My question is: is there some way to know in advance what hardware will work? I’d hate to go through this again and have the same result.

You should really be asking this in the issues section of Lizzie’s GitHub rather than here. They are better suited to help diagnose what problems you were encountering… it’s possible the hardware was not at fault, but since you have already sent the laptop back that is kinda hard to test now…

1 Like

It should install properly, even tf there were no GPU. Installation usually is just creating files.

1 Like

I am far from a professional on the matter, but from the little experience I have - if you want OpenCL, go with Nvidia. Sadly AMD cards seems to often NOT work out of the box (if at all) and require fiddling with drivers or even registry.

If you already returned the laptop then there is not much more to do, I guess.


Haven’t returned it yet as Covid has slowed everything down and I won’t hear back from customer service for over a week most likely. So, if anyone has any suggestions I’m open to them.

I found a thread on Reddit about hardware for Leela and apparently GeForce GTX 1080 is a good choice and that’s Nvidia. If I can’t make anything happen with the current laptop and they’ll take it back I might try one with this card.

Found a thread on lifein19x19 forum with the same problem. It led me to the Lizzie console where I found this error message:
“Uncaught exception: OpenCL error at C:\Data\Data\Coding\Python\KataGo\cpp\neuralnet\openclhelpers.cpp, func err, line 188, error CL_PLATFORM_NOT_FOUND_KHR”

I checked and I have the openCL DLL and it is supported by my video card so not sure where to go from here.

As suggested, I think I’ll take this to the github forum as it’s getting pretty technical.

1 Like

That’s an problem in KataGo. An error occurred when KataGo tried to get a list of available opencl devices.

I check directly, if KataGo works as expected (as described in
and would try the newest version of KataGo (opencl version)