Tsumego Hero Registration not Working

When I enter my information on the “Sign Up” page and press “Submit”, it just gives an error “The password should have at least 4 characters”, which doesn’t make any sense, as my password has 36 characters, which is well over the minimum given

I’m not sure where else to ask, so does anyone know how to get this to work?

I’m somewhat involved in that site. Will forward your message to the guy running it.


Thanks :slight_smile:

Got this so far:

Probably a special characters issue.

1 Like

I tried registering with a password containing only letters and numbers, and it still gave the same error (before I was trying with one including special characters)

Forwarded. Gosh, this feels silly! :smile:

1 Like

Thanks for your patience and help :slight_smile: Maybe this thread can help other people in the future, too, if we find a solution

I haven’t used that site for a long time. I just tried to sign in again and it didn’t work. I didn’t get any error message but I’m still not logged in.

What site do you use?

Were you asking the question to me? I was talking about the same site as you, Tsumego Hero. I went to the page Tsumego Hero - Sign In and entered the password that was stored on my computer and it sent me back to the homepage tsumego-hero.com, and I’m still not logged in.

Try clearing your cookies. There were changes recently that caused problems and clearing cookies solved that for me eventually.

Ah thanks, clearing cookies and cache didn’t work, but after clearing site settings it works again.

Yeah, sorry, I quoted the wrong thing. I meant, if you don’t use Tsumego Hero, what site do you use for tsumego

Well, for a long time I didn’t do much tsumegos apart from the daily tsumegos on the app Tsumego Pro because I wanted to read 4-5 books and it takes a lot of time… I know that other people use blacktoplay, 101weiqi, BadukPop, Tsumego Dragon but I haven’t used them, or haven’t used them as much. Now I’m back on tsumego-hero and I see it improved a lot since I left, a lot of new problems have been added. In addition many problems now say “correct but what about this other answer?” and consider the problem solved only after you give the second refutation.

1 Like

https://blacktoplay.com no registration needed

I don’t mind registering; I just can’t right now

Still no success? I use the site all the time, there were a few hiccups after a recent update, but all gone now (for me).

1 Like

I can try again

EDIT: Nope, same error

Does anyone have the regex which filters invalid passwords? that fixed a similar issue I had with another website

I’ve pointed the guy running that site to this thread now. It’s a hobby project for him, so not sure how quickly he will react.

1 Like

OK, I don’t really get it, but seemingly the problem is special characters being inserted even if you don’t type any. So it might be similar to what you encountered on another website???

One suggestion might be to try copy and pasting passwords. (I don’t really understand that suggestion, just passing on.)