Broken Games?

For some reason, some of my games I am no longer able to get into. They are all correspondence games. The only thing I can see is my opponent’s name on the home page. I am unable to see how many moves were played, the time left for both players, and the game name. When I go into the page, I get an empty board with not all of the controls available. I was planning on pausing all of those games; however, I do not see the pause button. I tried to refresh the page, but I nothing… I tried on a different web browser and even a different device entirely. However, nothing has changed. I am worried that I will end up timing out of all my games that I can no longer access.


i came here to report that i have the same problem, i think games where it is my turn can`t be loaded…

I’m glad I am not the only one having this issue. I didn’t really search up if anyone else had this issue since I was super worried :sweat_smile:
But because we all have this issue, I just hope our game times are frozen and not still ticking down…

1 Like

The discussion has already been started in this thread: Games stuck on "loading"

Looks like @yebellz’s high score of 7 has been beaten :smile:


Thanks for letting me know :slight_smile:


Sorry about the trouble y’all, as stated above, please see: Games stuck on "loading" for details and any potential further discussion.

Thank you :slight_smile:

1 Like