Congratulations I have found a bug

I have gotten the message “Congratulations, you found a bug!” a few times the last few days. It is quite randomly popping up when I go to someones profile page or now when I clicked SGF Library. I reload the page a few times and the message stays until I go away and back.

Also when some of my automatches have started I have come to an empty board and players “Black” and “White” with a loading message and something like 13 people in chat but I can’t write anything.

I have tried clearing cookies but it didn’t help. Anything else I can try?

1 Like

The last few games I played (using “Find a Game”) also come up with an empty board, no I.D. for players Black and White, a “Loading” message across the board, and 13 to 16 in the chat box as well. It also did not respond to my input.

But the last 2 times that happened, I went into my profile and clicked on the game board there, and “Voila!” I’m back in business, so the other player can get to the business of humiliating me instead of wondering where their opponent went.

But the first couple of times I encountered it I had to cancel the game (the first by closing the window, the second by cancelling the game) because I hadn’t figured out how to get it to work yet. I wasn’t “dinged” for either one.

My first question to Gurxtav is “Are you using Google Chrome?” My second is “Are you using Google Chrome and Windows 7?” If you answer “yes” to both questions then maybe you and I have the exact same problem for the same reason.


I am using Google Chrome but with Windows 10. Probably still the same issue though.

I also saw this (on Chrome, windows 10) 2 or 3 times in the lat 48 hours.

Trying jumping to profile and selecting the game and seeing if that fixes the problem until something can be done. I never had problems on this site with my Firefox, but the Mozilla people did something to Firefox in their last upgrade that screwed it up horribly. It works poorly on Windows 10 (my laptop) and doesn’t work at all on Windows 7 (my desktop).


I’m guessing the bug message is a new feature implemented for better error tracking? Haven’t heard anything about it but it’s certainly new.

The board loading problem is already a reported bug.

1 Like

That Bug report you posted isn’t exactly what I get…there’s no notification icon or anything. I have to go to my profile to find my way to the game. When the challenge is accepted I get the board with the “Loading” message, but there is no response to my mouse except for the “locations” up top.

But for all that, it could be the exact same thing, just visualized differently through a different browser.


Just got this when I went to my OGS “Home” page:

1 Like

This specific one should be fixed up now FTR.


Good, Thank you. Most excellent.


1 Like