Library Upload Not Working

MacBook, Chrome

First time I am seeing paste SGF option, which is clickable. But click on the Upload button goes no where.

I’ve been using upload all the time with no problem.

Any chance upload broke due to introduction of the paste option?

PS: Safari works.

Hmm I just tried this in Chrome on Mac, and it worked as expected. Same with Firefox on Android fwiw.

Anyone else able to reproduce?

Yeah I can say that my version of chrome on mac the upload button doesn’t do anything when clicked.

It doesn’t pop up an option to choose a file as happens in Safari

1 Like

Almost nothing has changed on that page with the introduction of the paste button (clicking the upload button still calls the exact same code path), so I wonder if this is an issue with the dropzone which accepts files. What version of Chrome are you two using, and if you drag and drop a file over the SGF library list does it upload as expected?

It’s not necessarily broken in this update, but just noticeable now.

It’s possible, thought this person did not really give any details that this person could’ve also had issues with the upload button for instance.

Actually speaking of versions, apparently I needed to relaunch chrome to finish an update and now its working.

1 Like

I found a very similar issue described here.

It also looks like a fix for the issue was committed only a few minutes ago as I type this :laughing:

One way to test if this is the root cause might be to go to this page and try clicking the “Open File Dialog” button. If it doesn’t work, then this dropzone bug is almost surely the cause.


My Chrome version: Version 105.0.5195.125 (Official Build) (arm64)
Mac: MacBook Air(M1, 2020), macOS Monterey Version 12.5.1

Update: I tried a classic MS Windows remedy, reboot, :sweat_smile:now it works. Prior to this, I tried logout and relaunch Chrome, it did not work.