Seeking debug information from those with blank screen problems

Hello All,

There have been a number of reports of folks seeing only a blank screen when accessing OGS. This seems to happen on several devices and several browsers, but I have not been able to reproduce it.

If you have a device that is exhibiting this behavior and are able to access the debug console, I would greatly appreciate any error messages that you see there.

Thanks!

- anoek

1 Like

I don’t know how to access the debug console in android.
I can report that I no longer see a blank page after clearing the cache data for the site (accessed by using Menu -> Settings ->Content settings -> Website settings then finding online-go.com in the long list available there).
However the site seems to not be working (I can see a front page with live games going on but can’t open any menu and cliquing on one of the game doesn’t bring me to the game page).

Thanks for the time you’re putting into this!

EDIT: Reloading the page led to a blank page again. :confused:
If I have instructions on how to access the debug console I’m willing to report what’s there.

2 Likes

Accessing the debug console on android takes a little bit but basically you connect your phone to the chrome javascript console, so you can see all the logs and such through the chrome javascript panel (it’s really rather slick actually):

That’s very interesting that it worked then it didn’t… I’d love to get a peak at those logs :slight_smile:

2 Likes

Update: I just found and fixed a bug that would cause this, it could happen with some various combinations of language settings on the device.

Can folks who have had this issue retry and see if things re behaving any better? Thanks!

- anoek

4 Likes

Similar to statements by others, I cannot access the main OGS server. I have Window 8.1 and am using IE, I managed to get into the forum by searching for it on Bing and clicking rather than through OGS. It recognizes me without my user name or password, presumably through the IP.

When I tried to log in last night I initially got the same message others got, “Type Error…‘assign.’” Unfortunately I made several attempts at retyping (possibly exceeding a limit you may have on attempts). Subsequently, I get a blank screen when I try to access OGS, which I thought might be because my IP is being blocked due to the several failed attempts. Tonight I also got a blank screen, whether through a search listing or directly typing the url.

Other threads here suggest this may be a browser problem, so I intend to download and try Firefox and Chrome.

Hallelujah! Firefox works, and I’m back in business on OGS!

3 Likes

It still doesn’t work for me. :confused:
Thanks for the link to how to use the console, I’ll give it a try tonight and let you know how it turned out.

OK well it did not work out.
I think my version of chrome is outdated as I have a 32 bits computer at home.
Therefore the instructions didn’t match what I was seeing (I got stuck at finding the main menu in the dev tools ! :smiley: )

Sorry I couldn’t help.

Works fine in Firefox, but I get a big blank screen in Pale Moon (my preferred browser). All add-ons are disabled (“safe mode”). Windows 7. These are the log entries from the “JS” tab in the dev console:

"Welcome to OGS" online-go.com:180:12
SyntaxError: missing ; before statement online-go.com:139:20
mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create es6-shim.min.js:10:23900
calling a builtin Map constructor without new is deprecated and will be forbidden in ES6 es6-shim.min.js:11:16286
calling a builtin Set constructor without new is deprecated and will be forbidden in ES6 es6-shim.min.js:11:16858
TypeError: asm.js type error: Disabled by javascript.options.asmjs in about:config OGSScoreEstimator.5.0-453-g6e0f859.js
TypeError: t.current_language is undefined ogs.5.0-453-g6e0f859.js:1:4415

Hope this helps. Let me know if you want any more information.

1 Like

I’m using Chrome on Linux Mint, which works. Qutebrowser will load the blank screen reliably. From the error console:

SyntaxError: Expected an identifier but found ‘set_lang’ instead online-go.com:139
Welcome to OGS online-go.com:180
Failed to load resource: %HOSTBLOCK% https://www.google-analytics.com/analytics.js
Failed to load resource: %HOSTBLOCK% https://sb.scorecardresearch.com/beacon.js
Failed to load resource: %HOSTBLOCK% https://secure-us.imrworldwide.com/cgi-bin/m?ci=us-603339h&cg=0&cc=1&si=https%3A//online-go.com/&rp=&ts=compact&rnd=1487204966695
TypeError: ‘undefined’ is not an object (evaluating ‘t.countries[t.current_language]’) ogs.5.0-453-g6e0f859.js:1

I am having the problem since about 8 hours ago. I use Firefox and suddenly the site won’t load. Stops with URL at https:/online-go.com and a white blank screen. Tried deleting cache but no change. Accessed with Microsoft Internet Explorer (which I hate) and of course it works OK.

ALSO, I am involved in a tournament that has been going on for the past YEAR AND A HALF

Can I please suggest to stop ALL CLOCKS until this transition to the new version gets the bugs worked out???

It would REALLY suck to get disqualified because I can’t log in.

http://pastebin.com/0x93QcbC

Above is a pastebin of the white blank screen when trying to access online-go.com with FireFox.

Posted as requested by crocobot.

this is from HikaruTim: http://pastebin.com/0x93QcbC

[Error] SyntaxError: Unexpected identifier ‘set_lang’
(anonymous function) (online-go.com:178)
[Error] TypeError: undefined is not an object (evaluating ‘t.current_language’)
(anonymous function) (ogs.5.0-453-g6e0f859.js:1:4430)
t (ogs.5.0-453-g6e0f859.js:1:106)
(anonymous function) (ogs.5.0-453-g6e0f859.js:1:15822)
t (ogs.5.0-453-g6e0f859.js:1:106)
(anonymous function) (ogs.5.0-453-g6e0f859.js:1:9036)
t (ogs.5.0-453-g6e0f859.js:1:106)
(anonymous function) (ogs.5.0-453-g6e0f859.js:47:27715)
t (ogs.5.0-453-g6e0f859.js:1:106)
(anonymous function) (ogs.5.0-453-g6e0f859.js:1:486)
global code (ogs.5.0-453-g6e0f859.js:1:496)

Here’s the console output on safari. I’m using Safari Version 9.1.2 (11601.7.7).
The page is completely blank.

Chrome 48.0.2564.116 (64-bit) on Ubuntu 12.04; error is on line 178 of the page itself (same as Spatula’s)

let set_lang = JSON.parse(localStorage.getItem('ogs.preferences.language') || 'null');

The error message is Uncaught SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode

Yep, there is definitely something going on with the languages. All three posts above have a problem with “t.current_language” or “set_lang”.

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (ogs.min.js.map, line 0)
[Error] SyntaxError: Unexpected identifier ‘set_lang’
(anonymous function) (online-go.com, line 178)
[Log] Welcome to OGS (online-go.com, line 221)
[Error] TypeError: undefined is not an object (evaluating ‘t.countries[t.current_language]’)
(anonymous function) (ogs.5.0-453-g6e0f859.js, line 1)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (ogs.min.js.map, line 0)

OK I see what I did wrong, I think that error should be fixed now.

How are the blank screens now, and if you still see them, are there new errors on the JS console?

1 Like