"Challenge Links" prototype for testing at Beta - more testing, please :)

Beta now has a “prototype” of a new feature I’ve been calling “Challenge Links”.

The basic idea is that you can get a URL for a challenge that you have created, and send it to another person, who can use that URL to find and accept the challenge.

  • You can get the link to open challenges from the Play page.

  • Anyone with the URL can “visit/click” the URL to get to a dialog that will let them accept it.

    • If they aren’t an OGS user and they proceed, they will be created a Guest account to play with.
      • There are some help popups for guests like this. These are very early work, but feedback is welcome.
    • If the person is logged out, but they are a member, they can log-in on the way in.
  • You can mark a Challenge “invite only”. This means that it won’t show up in the Play page, instead it shows up on your home page … and only people with the URL (but anyone with the URL) can accept.

  • Challenge Links work for Rengo. When you “accept” using the URL it joins you into a team.

There should be a zillion ways to break this, because it is quite complicated under the hood:

There are permutations of all these parameters that need to work:

  • Rengo/Not Rengo
  • Logged in/Not Logged in
  • Member/Not member
  • Login via account
  • Login via SSO
  • Invite-Only or Open

Testing welcome, much appreciated.

I’ll start a bug list in this post, once you start reporting them :slight_smile:


  • Something odd about “waiting for rengo players” even if it is not a rengo challenge.
    - Doh, don’t show the “manage” button for non-rengo games!

  • No “Challenge accepted (link copied)” dialogs for invite-only rengo live challenges

  • It should tell you if the link “expired” (probably due to game started, or challenge being removed)

  • Critical: guests can’t change their password

  • Sometimes an invite link returns null

  • Invite only challenges not appearing on home page

  • The dialog on the accept page should tell you if it’s a Rengo game - that label is missing. fixed

  • “TypeError: Cannot use ‘in’ operator to search for ‘right-nav-help’ in undefined”. should be fixed?


Don’t want to clog this thread but just have to say that this is spectacular!


Very exciting new feature! Tried to break it a bit:

I tried accepting this rengo challenge when not logged in and got a big popup “TypeError: Cannot use ‘in’ operator to search for ‘right-nav-help’ in undefined”.

Also I don’t see any of the invite-only challenges on my home page.


Thanks - I can reproduce that, will get it fixed.

Would you be able to list combinations/flows that you tried that did work?

Would be nice to get some idea of how much it’s been kicked :slight_smile:


I mean, W O W. :exploding_head::partying_face:

That’s all.




This new feature is built on top of an experimental new layout of the Nav and Home page.

I guess I better put it into the “old” layout so you all can actually test it! :open_mouth:

In the mean time, for those that know how, this will get you the new layout, and then the new Home page should work with invite-only challenges:

data.set("experiments.v6", "enabled");

(I can’t imagine going back to the old layout :wink: )

1 Like

The two downsides for me are how buried the search bar is and that the new layout lost the blue chat indicator from the top

1 Like

Mmm - I guess these will be the topics of some discussion and experimentation eh.

The search bar is only one click away on a phone - and not even a click on the desktop: I wouldn’t call that “deep” …and of course there’s the upside of how clean it all looks as a result.

But I can see that these sorts of things are the reason why it’s not rolled out as “done” already.

Ah well, I guess I better get on with putting invite-only’s in the old Home page :slight_smile:

1 Like

I created a Challenge “invite only”, and the game link was copied to my clipboard, but I can’t see it on my home page. Can anyone see it?

Just in case: the challenge is this one. Play Go at online-go.com! | OGS

1 Like

First attempt:

Correspondence, tried to accept as a guest. Then I tried again and it worked.

Have you tried clicking “paste”?

1 Like

Yes, “paste” does work. But if I happened to lose the link, I couldn’t find it again.

1 Like

Clicked, accepted (with a registered account) and no game started. Same as a guest.

Then I tried to open @jlt 's profile to see if something else started:

1 Like

The thing is that it’s a rengo game. But I can’t see where I can manage the game.

1 Like

This is the same as:

… the rengo match is on your Home page … in the new view :slight_smile:

Standby, I’m hoping both those Type Errors and this problem go away with the next update!

(But you can get further if you are able to turn on experimental mode).

1 Like

I see that bug screen also when I click on “settings”.

1 Like

I accidentally created two challenges but nothing happened and now I can’t create more.

It could be the board size, it could be the restrict rank check. I can try to isolate it on another account.

1 Like

Heh heh I suspect this is all part of the “darn, GaJ was using the new Home but the testers have the old Home”.

I see that you have Invite-only checked.

When “nothing happened”, it should have said “Challenge Created [OK]” and “Challenge Link Copied”

You’re expected to paste the copied link in your email to your friend, and navigate to your home page if you want to look at your invite-only challenge. Which you can’t currently see unless you’re on the experimental setting :sob:

Now that you already have two open live challenges, you’re stuck because you can’t delete them because they’re on the Home page where you can’t see them :smiley:

At least, that’s my guess?


Oh yeah, let me swap to that, I knew I was supposed to do something :stuck_out_tongue:

I’ll try again :slight_smile:

Edit: okay I can cancel the open challenges, but still don’t get any message about being copied etc. I’ll try isolate what it is.

1 Like

Yeah I can’t get that to work, on Chrome or safari. It seems like there’s some console error possibly preventing it.

When I look at challenges I see the following and when I click manage, there’s a “Waiting for Rengo players” even though it’s not Rengo. However if I try to join my own challenge then it tells me it doesn’t exist.

I must be doing something wrong. Also the clock “1m” should be “10m” for those absolute challenges.

Also when I click the arrow → to copy the link manually it looks like


It looks like I can create a challenge when I don’t tick “invite-only”

1 Like

I’m not sure why that was happening, but now I can’t make it do it again reliably :stuck_out_tongue:

1 Like