Wrong move submitted (J19 bug)

Hi,

I’ve encountered the J19 bug twice in a correspondance game i’m currently playing. To summarize, when preparing a move all of a sudden a move is submitted on the top row of the board. In my case it was E19. Luckily my opponent was nice enough to let me undo twice.

In my case it happened both times on my iPad using Safari. Also it happened both times in analyze mode, while fumbling my ipad, i.e. I don’t know exactly where I touched the screen and all of a sudden the E19 move was submitted. What ever I did, i’m pretty sure that there wasn’t any stone at E19 when it happened.

After searching I’ve found multiple threads about it which I’ll list below. All of the threads are quite old, so I just wanted to notify that the bug is still around. I understand that these type of “random” bugs are annoying to squash and I hope I can help. Now that I’ve read a little about this problem I’m a bit more aware what to look for, if it happens again.

Related Threads:






3 Likes

Hi Jann5s,

Thanks for the report and the digging things up, you’ll be happy to know that I was finally able to locate and fix this bug, it should finally be solved for good in the upcoming major release.

  • anoek
3 Likes

The bug is still in the analyse mode. If I start the analyse mode, a stone is immediately placed on the first line of the board. It is no problem for me to ignore the stone. After returning from analyse mode anything is ok and I can place my move where I want.

Hardware: iPad4 Software: iOS 10.1.1(14B100)

1 Like

Now the bug is on the second line. In my game https://online-go.com/game/6819301: A Stone was put on H18. My Fingers never touched this area of the board. Sorry, but OGS is still not an option for playing Go on the iPad.

You understand that the patch hasn’t been released yet right…

2 Likes

Thanks! How do I get information about current software version and new releases?

The forum is the best place, but there’s also a changelog on the bottom of the homepage.

1 Like